An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4…
Priority LOW 21CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to retrieve some configuration information about Gerrit in Jenkins.
Why it matters now
EPSS 0.00663 51st percentileScored 2026-11-07
Fix Fixed com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): 2.27.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) | before 2.27.5 | 2.27.5 | Patch available | GHSA-wrqc-q8p5-76m5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Vendor— Affected before 2.27.5 Fixed in 2.27.5 Patch available GHSA-wrqc-q8p5-76m5
Remediation
- Fix · GHSA-wrqc-q8p5-76m5 com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Fixed in 2.27.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000105
- 2026-10-03 Alias added: GHSA-wrqc-q8p5-76m5
- 2026-10-06 EPSS moved to the 50th–90th percentile
References
More Jenkins Gerrit Trigger vulnerabilities
- TI-2019-12413 Cross-site request forgery in Jenkins Gerrit Trigger Plugin CVSS 3.1HIGH 8.8
- TI-2023-10045 Cross-site request forgery in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 6.5
- TI-2022-11605 Cross-site scripting in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 5.4
- TI-2018-15759 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 5.4
- TI-2019-12414 Incorrect default permissions in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2018-1000105 · CVE Program
- CVE-2018-1000105 · NVD
- FIRST EPSS
- GHSA-wrqc-q8p5-76m5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences