Cross-site scripting in Jenkins Gerrit Trigger Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Gerrit Trigger Plugin 2.35.2 and earlier does not escape the name and description of Base64 Encoded String parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.0083 57th percentileScored 2026-11-07
Fix Fixed com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): 2.35.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Gerrit Trigger Plugin | up to 2.35.2 | — | No fix listed | CNA |
| — | com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) | before 2.35.3 | 2.35.3 | Patch available | GHSA-455j-8hg5-8576 |
- Jenkins Gerrit Trigger Plugin VendorJenkins Affected up to 2.35.2 Fixed in — No fix listed CNA
- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Vendor— Affected before 2.35.3 Fixed in 2.35.3 Patch available GHSA-455j-8hg5-8576
Remediation
- Fix · GHSA-455j-8hg5-8576 com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Fixed in 2.35.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29039
- 2026-10-03 Alias added: GHSA-455j-8hg5-8576
References
More Jenkins Gerrit Trigger vulnerabilities
- TI-2019-12413 Cross-site request forgery in Jenkins Gerrit Trigger Plugin CVSS 3.1HIGH 8.8
- TI-2023-10045 Cross-site request forgery in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 6.5
- TI-2018-15759 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 5.4
- TI-2019-12414 Incorrect default permissions in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 5.4
- TI-2018-15758 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 4.3
Sources
- CVE-2022-29039 · CVE Program
- CVE-2022-29039 · NVD
- FIRST EPSS
- GHSA-455j-8hg5-8576 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences