Cross-site request forgery in Jenkins Gerrit Trigger Plugin
Priority LOW 29CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins Gerrit Trigger Plugin 2.38.0 and earlier allows attackers to rebuild previous builds triggered by Gerrit.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.005 43rd percentileScored 2026-11-07
Fix Fixed com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): 2.38.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Gerrit Trigger Plugin | up to 2.38.0 | — | No fix listed | CNA |
| — | com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) | before 2.38.1 | 2.38.1 | Patch available | GHSA-95jq-24cr-pgrq |
- Jenkins Gerrit Trigger Plugin VendorJenkins Affected up to 2.38.0 Fixed in — No fix listed CNA
- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Vendor— Affected before 2.38.1 Fixed in 2.38.1 Patch available GHSA-95jq-24cr-pgrq
Remediation
- Fix · GHSA-95jq-24cr-pgrq com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Fixed in 2.38.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-24423
- 2026-10-03 Alias added: GHSA-95jq-24cr-pgrq
References
More Jenkins Gerrit Trigger vulnerabilities
- TI-2019-12413 Cross-site request forgery in Jenkins Gerrit Trigger Plugin CVSS 3.1HIGH 8.8
- TI-2022-11605 Cross-site scripting in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 5.4
- TI-2018-15759 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 5.4
- TI-2019-12414 Incorrect default permissions in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 5.4
- TI-2018-15758 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 4.3
Sources
- CVE-2023-24423 · CVE Program
- CVE-2023-24423 · NVD
- FIRST EPSS
- GHSA-95jq-24cr-pgrq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences