Incorrect default permissions in Jenkins Gerrit Trigger Plugin
Priority LOW 25CWE-276Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
A missing permission check in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials, or determine the existence of a file with a given path on the Jenkins master.
Why it matters now
EPSS 0.00622 50th percentileScored 2026-11-07
Fix Fixed com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): 2.30.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Gerrit Trigger Plugin | up to 2.30.1 | — | No fix listed | CNA |
| — | com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) | before 2.30.2 | 2.30.2 | Patch available | GHSA-4r39-f4rh-j6q8 |
- Jenkins Gerrit Trigger Plugin VendorJenkins Affected up to 2.30.1 Fixed in — No fix listed CNA
- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Vendor— Affected before 2.30.2 Fixed in 2.30.2 Patch available GHSA-4r39-f4rh-j6q8
Remediation
- Fix · GHSA-4r39-f4rh-j6q8 com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Fixed in 2.30.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16552
- 2026-10-03 Alias added: GHSA-4r39-f4rh-j6q8
- 2026-11-07 EPSS moved to the 50th–90th percentile
References
More Jenkins Gerrit Trigger vulnerabilities
- TI-2019-12413 Cross-site request forgery in Jenkins Gerrit Trigger Plugin CVSS 3.1HIGH 8.8
- TI-2023-10045 Cross-site request forgery in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 6.5
- TI-2022-11605 Cross-site scripting in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 5.4
- TI-2018-15759 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 5.4
- TI-2018-15758 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 4.3
Sources
- CVE-2019-16552 · CVE Program
- CVE-2019-16552 · NVD
- FIRST EPSS
- GHSA-4r39-f4rh-j6q8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences