Read the docs
TI-2019-12413 Aliases CVE-2019-16551GHSA-vmvp-2hhx-rgm8

Cross-site request forgery in Jenkins Gerrit Trigger Plugin

Priority MEDIUM 40CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A cross-site request forgery vulnerability in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials.

Why it matters now

EPSS 0.00859 58th percentileScored 2026-11-07
Fix Fixed com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): 2.30.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Gerrit Trigger Pluginup to 2.30.1—No fix listedCNA
—com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven)before 2.30.22.30.2Patch availableGHSA-vmvp-2hhx-rgm8
  • Jenkins Gerrit Trigger Plugin VendorJenkins Affected up to 2.30.1 Fixed in — No fix listed CNA
  • com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Vendor— Affected before 2.30.2 Fixed in 2.30.2 Patch available GHSA-vmvp-2hhx-rgm8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:gerrit_trigger:*:*:*:*:*:jenkins:*:*up to 2.30.1VulnerableJenkins
  • cpe:2.3:a:jenkins:gerrit_trigger:*:*:*:*:*:jenkins:*:* Versions up to 2.30.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-vmvp-2hhx-rgm8 com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven) Fixed in 2.30.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-16551
  2. 2026-10-03 Alias added: GHSA-vmvp-2hhx-rgm8
  3. 2026-11-03 Priority changed: LOW → MEDIUM

References

  • TI-2023-10045 Cross-site request forgery in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 6.5
  • TI-2022-11605 Cross-site scripting in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 5.4
  • TI-2018-15759 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 5.4
  • TI-2019-12414 Incorrect default permissions in Jenkins Gerrit Trigger Plugin CVSS 3.1MEDIUM 5.4
  • TI-2018-15758 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4… CVSS 3.0MEDIUM 4.3

Sources