Path traversal in Red Hat Ansible
Priority LOW 20CWE-22Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 6 fixed, 11 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.
Why it matters now
EPSS 0.00522 44th percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.5.15, 2.6.14, 2.7.8Red Hat: 6 advisoriesRed Hat: 6 fixed, 11 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Ansible | 2.5.15; 2.6.14; 2.7.8 | — | No fix listed | CNA |
| — | ansible (PyPI) | before 2.5.15 | 2.5.15 | Patch available | GHSA-74vq-h4q8-x6jv |
| — | ansible (PyPI) | 2.6.0a1 to before 2.6.14 | 2.6.14 | Patch available | GHSA-74vq-h4q8-x6jv |
| — | ansible (PyPI) | 2.7.0a1 to before 2.7.8 | 2.7.8 | Patch available | GHSA-74vq-h4q8-x6jv |
- Ansible VendorRed Hat Affected 2.5.15; 2.6.14; 2.7.8 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 2.5.15 Fixed in 2.5.15 Patch available GHSA-74vq-h4q8-x6jv
- ansible (PyPI) Vendor— Affected 2.6.0a1 to before 2.6.14 Fixed in 2.6.14 Patch available GHSA-74vq-h4q8-x6jv
- ansible (PyPI) Vendor— Affected 2.7.0a1 to before 2.7.8 Fixed in 2.7.8 Patch available GHSA-74vq-h4q8-x6jv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* | 2.5.0 to before 2.5.15; 2.6.0 to before 2.6.14; 2.7.0 to before 2.7.8 | Vulnerable | Red Hat |
- cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions 2.5.0 to before 2.5.15; 2.6.0 to before 2.6.14; 2.7.0 to before 2.7.8 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-74vq-h4q8-x6jv ansible (PyPI) Fixed in 2.5.15 Advisory →
- Fix · GHSA-74vq-h4q8-x6jv ansible (PyPI) Fixed in 2.6.14 Advisory →
- Fix · GHSA-74vq-h4q8-x6jv ansible (PyPI) Fixed in 2.7.8 Advisory →
Red Hat 6 advisories
- RHSA-2019:3789 Released 2019-11-07 · Red Hat rating Moderateansible security update
- Red Hat OpenStack Platform 13.0 ansible-2.6.19-1.el7ae
- RHSA-2019:3744 Released 2019-11-06 · Red Hat rating Moderateansible security update
- Red Hat OpenStack Platform 14.0 ansible-2.6.19-1.el7ae
- RHSA-2019:0433 Released 2019-02-28 · Red Hat rating Moderateansible security and bug fix update
- Red Hat Ansible Engine 2.6 for RHEL 7 Server ansible-2.6.14-1.el7ae
Show 3 more Red Hat advisories
- RHSA-2019:0432 Released 2019-02-28 · Red Hat rating Moderateansible security and bug fix update
- Red Hat Ansible Engine 2.5 for RHEL 7 Server ansible-2.5.15-1.el7ae, ansible-doc-2.5.15-1.el7ae
- RHSA-2019:0431 Released 2019-02-28 · Red Hat rating Moderateansible security and bug fix update
- Red Hat Ansible Engine 2.7 for RHEL 7 Server ansible-2.7.8-1.el7ae
- RHSA-2019:0430 Released 2019-02-28 · Red Hat rating Moderateansible security and bug fix update
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.7.8-1.el7ae
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Out of support scope |
| Red Hat Ansible Tower 3 | Affected | No fix yet |
| Red Hat Ceph Storage 2 | Affected | No fix yet |
| Red Hat Ceph Storage 3 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.2 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.3 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.4 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.5 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat Ansible Engine 2 for RHEL 7 | Fixed | RHSA-2019:0430 |
| Red Hat Ansible Engine 2.5 for RHEL 7 Server | Fixed | RHSA-2019:0432 |
| Red Hat Ansible Engine 2.6 for RHEL 7 Server | Fixed | RHSA-2019:0433 |
| Red Hat Ansible Engine 2.7 for RHEL 7 Server | Fixed | RHSA-2019:0431 |
| Red Hat OpenStack Platform 13.0 | Fixed | RHSA-2019:3789 |
| Red Hat OpenStack Platform 14.0 | Fixed | RHSA-2019:3744 |
Not affected: 1 product
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3828
- 2026-10-03 Alias added: GHSA-74vq-h4q8-x6jv
References
Patch 2
Advisory 8
Other 7
- http://packetstormsecurity.com/files/172837/Ansible-Fetch-Path-Traversal.html
- https://github.com/ansible/ansible/commit/396a2f74717477d80600450e2b7e45349d7b5110
- https://github.com/ansible/ansible/commit/4be3215d2f9f84ca283895879f0c6ce1ed7dd333
- https://github.com/ansible/ansible/commit/f3edc091523fbe301926b7a0db25fbbd96940d93
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2019-5.yaml
- https://usn.ubuntu.com/4072-1
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-3828 · CVE Program
- CVE-2019-3828 · NVD
- FIRST EPSS
- GHSA-74vq-h4q8-x6jv · GitHub Advisory Database · CC BY 4.0
- CVE-2019-3828 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences