Read the docs
TI-2019-07634 Aliases CVE-2019-10325GHSA-wrr5-p265-7252

Cross-site scripting in Jenkins Warnings NG Plugin

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.

Why it matters now

EPSS 0.01077 65th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:warnings-ng (Maven): 5.1.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Warnings NG Pluginup to 5.0.0—No fix listedCNA
—io.jenkins.plugins:warnings-ng (Maven)before 5.1.05.1.0Patch availableGHSA-wrr5-p265-7252
  • Jenkins Warnings NG Plugin VendorJenkins Affected up to 5.0.0 Fixed in — No fix listed CNA
  • io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected before 5.1.0 Fixed in 5.1.0 Patch available GHSA-wrr5-p265-7252

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:*up to 5.0.0VulnerableJenkins
  • cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:* Versions up to 5.0.0 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-wrr5-p265-7252 io.jenkins.plugins:warnings-ng (Maven) Fixed in 5.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10325
  2. 2026-10-03 Alias added: GHSA-wrr5-p265-7252

References

  • TI-2019-15853 Cross-site request forgery in Jenkins Warnings Next Generation Plugin CVSS 3.0HIGH 8.8
  • TI-2022-07276 Path traversal in Jenkins Warnings Next Generation Plugin CVSS 3.1HIGH 8.1
  • TI-2019-15868 Cross-site scripting in Jenkins Warnings Next Generation Plugin CVSS 3.0MEDIUM 6.1
  • TI-2021-04706 Missing authorization in Jenkins Warnings Next Generation Plugin CVSS 3.1MEDIUM 4.3
  • TI-2019-07635 Cross-site request forgery in Jenkins Warnings NG Plugin CVSS 3.0MEDIUM 4.3

Sources