Path traversal in Jenkins Warnings Next Generation Plugin
Priority LOW 39CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.
Why it matters now
EPSS 0.01949 80th percentileScored 2026-11-07
Fix Fixed Jenkins Warnings Next Generation Plugin (Jenkins project): 9.0.2, 9.5.2, 9.7.1io.jenkins.plugins:warnings-ng (Maven): 9.10.3, 9.7.1, 9.5.2 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Warnings Next Generation Plugin | up to 9.10.2 | 9.0.2, 9.5.2, 9.7.1 | Patch available | CNA |
| — | io.jenkins.plugins:warnings-ng (Maven) | 9.8.0 to before 9.10.3 | 9.10.3 | Patch available | GHSA-rvh4-g2rj-hr9c |
| — | io.jenkins.plugins:warnings-ng (Maven) | 9.6.0 to before 9.7.1 | 9.7.1 | Patch available | GHSA-rvh4-g2rj-hr9c |
| — | io.jenkins.plugins:warnings-ng (Maven) | 9.1.0 to before 9.5.2 | 9.5.2 | Patch available | GHSA-rvh4-g2rj-hr9c |
| — | io.jenkins.plugins:warnings-ng (Maven) | before 9.0.2 | 9.0.2 | Patch available | GHSA-rvh4-g2rj-hr9c |
- Jenkins Warnings Next Generation Plugin VendorJenkins Affected up to 9.10.2 Fixed in 9.0.2, 9.5.2, 9.7.1 Patch available CNA
- io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected 9.8.0 to before 9.10.3 Fixed in 9.10.3 Patch available GHSA-rvh4-g2rj-hr9c
- io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected 9.6.0 to before 9.7.1 Fixed in 9.7.1 Patch available GHSA-rvh4-g2rj-hr9c
- io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected 9.1.0 to before 9.5.2 Fixed in 9.5.2 Patch available GHSA-rvh4-g2rj-hr9c
- io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected before 9.0.2 Fixed in 9.0.2 Patch available GHSA-rvh4-g2rj-hr9c
Remediation
- Fix · CNA Jenkins Warnings Next Generation Plugin (Jenkins project) Fixed in 9.0.2, 9.5.2, 9.7.1
- Fix · GHSA-rvh4-g2rj-hr9c io.jenkins.plugins:warnings-ng (Maven) Fixed in 9.10.3 Advisory →
- Fix · GHSA-rvh4-g2rj-hr9c io.jenkins.plugins:warnings-ng (Maven) Fixed in 9.7.1 Advisory →
- Fix · GHSA-rvh4-g2rj-hr9c io.jenkins.plugins:warnings-ng (Maven) Fixed in 9.5.2 Advisory →
- Fix · GHSA-rvh4-g2rj-hr9c io.jenkins.plugins:warnings-ng (Maven) Fixed in 9.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23107
- 2026-10-03 Alias added: GHSA-rvh4-g2rj-hr9c
References
Advisory 3
More Jenkins Warnings Next Generation vulnerabilities
- TI-2019-15853 Cross-site request forgery in Jenkins Warnings Next Generation Plugin CVSS 3.0HIGH 8.8
- TI-2019-15868 Cross-site scripting in Jenkins Warnings Next Generation Plugin CVSS 3.0MEDIUM 6.1
- TI-2019-07634 Cross-site scripting in Jenkins Warnings NG Plugin CVSS 3.0MEDIUM 5.4
- TI-2021-04706 Missing authorization in Jenkins Warnings Next Generation Plugin CVSS 3.1MEDIUM 4.3
- TI-2019-07635 Cross-site request forgery in Jenkins Warnings NG Plugin CVSS 3.0MEDIUM 4.3
Sources
- CVE-2022-23107 · CVE Program
- CVE-2022-23107 · NVD
- FIRST EPSS
- GHSA-rvh4-g2rj-hr9c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences