Missing authorization in Jenkins Warnings Next Generation Plugin
Priority LOW 22CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform a permission check in methods implementing form validation, allowing attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents.
Why it matters now
EPSS 0.00857 58th percentileScored 2026-11-07
Fix Fixed Jenkins Warnings Next Generation Plugin (Jenkins project): 8.4.3.1io.jenkins.plugins:warnings-ng (Maven): 8.5.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Warnings Next Generation Plugin | up to 8.4.4 | 8.4.3.1 | Patch available | CNA |
| — | io.jenkins.plugins:warnings-ng (Maven) | before 8.5.0 | 8.5.0 | Patch available | GHSA-7j3x-xm4j-jfj7 |
- Jenkins Warnings Next Generation Plugin VendorJenkins Affected up to 8.4.4 Fixed in 8.4.3.1 Patch available CNA
- io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected before 8.5.0 Fixed in 8.5.0 Patch available GHSA-7j3x-xm4j-jfj7
Remediation
- Fix · CNA Jenkins Warnings Next Generation Plugin (Jenkins project) Fixed in 8.4.3.1
- Fix · GHSA-7j3x-xm4j-jfj7 io.jenkins.plugins:warnings-ng (Maven) Fixed in 8.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21626
- 2026-10-03 Alias added: GHSA-7j3x-xm4j-jfj7
References
More Jenkins Warnings Next Generation vulnerabilities
- TI-2019-15853 Cross-site request forgery in Jenkins Warnings Next Generation Plugin CVSS 3.0HIGH 8.8
- TI-2022-07276 Path traversal in Jenkins Warnings Next Generation Plugin CVSS 3.1HIGH 8.1
- TI-2019-15868 Cross-site scripting in Jenkins Warnings Next Generation Plugin CVSS 3.0MEDIUM 6.1
- TI-2019-07634 Cross-site scripting in Jenkins Warnings NG Plugin CVSS 3.0MEDIUM 5.4
- TI-2019-07635 Cross-site request forgery in Jenkins Warnings NG Plugin CVSS 3.0MEDIUM 4.3
Sources
- CVE-2021-21626 · CVE Program
- CVE-2021-21626 · NVD
- FIRST EPSS
- GHSA-7j3x-xm4j-jfj7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences