Read the docs

Cross-site scripting in Jenkins Warnings Next Generation Plugin

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in src/main/java/io/jenkins/plugins/analysis/core/model/DetailsTableModel.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourceDetail.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourcePrinter.java, src/main/java/io/jenkins/plugins/analysis/core/util/Sanitizer.java, src/main/java/io/jenkins/plugins/analysis/warnings/DuplicateCodeScanner.java that allows attackers with the ability to control warnings parser input to have Jenkins render arbitrary HTML.

Why it matters now

EPSS 0.01041 64th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:warnings-ng (Maven): 2.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Warnings Next Generation Pluginup to 1.0.1—No fix listedCNA
—io.jenkins.plugins:warnings-ng (Maven)before 2.0.02.0.0Patch availableGHSA-cqp7-hwm3-cfg7
  • Jenkins Warnings Next Generation Plugin VendorJenkins Affected up to 1.0.1 Fixed in — No fix listed CNA
  • io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-cqp7-hwm3-cfg7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:*up to 1.0.1VulnerableJenkins
  • cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:* Versions up to 1.0.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-cqp7-hwm3-cfg7 io.jenkins.plugins:warnings-ng (Maven) Fixed in 2.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003023
  2. 2026-10-03 Alias added: GHSA-cqp7-hwm3-cfg7

References

  • TI-2019-15853 Cross-site request forgery in Jenkins Warnings Next Generation Plugin CVSS 3.0HIGH 8.8
  • TI-2022-07276 Path traversal in Jenkins Warnings Next Generation Plugin CVSS 3.1HIGH 8.1
  • TI-2019-07634 Cross-site scripting in Jenkins Warnings NG Plugin CVSS 3.0MEDIUM 5.4
  • TI-2021-04706 Missing authorization in Jenkins Warnings Next Generation Plugin CVSS 3.1MEDIUM 4.3
  • TI-2019-07635 Cross-site request forgery in Jenkins Warnings NG Plugin CVSS 3.0MEDIUM 4.3

Sources