Cross-site request forgery in Jenkins Warnings NG Plugin
Priority LOW 22CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attackers to reset warning counts for future builds.
Why it matters now
EPSS 0.0103 63rd percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:warnings-ng (Maven): 5.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Warnings NG Plugin | up to 5.0.0 | — | No fix listed | CNA |
| — | io.jenkins.plugins:warnings-ng (Maven) | before 5.1.0 | 5.1.0 | Patch available | GHSA-px35-882c-47hw |
- Jenkins Warnings NG Plugin VendorJenkins Affected up to 5.0.0 Fixed in — No fix listed CNA
- io.jenkins.plugins:warnings-ng (Maven) Vendor— Affected before 5.1.0 Fixed in 5.1.0 Patch available GHSA-px35-882c-47hw
Remediation
- Fix · GHSA-px35-882c-47hw io.jenkins.plugins:warnings-ng (Maven) Fixed in 5.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10326
- 2026-10-03 Alias added: GHSA-px35-882c-47hw
References
More Jenkins Warnings Next Generation vulnerabilities
- TI-2019-15853 Cross-site request forgery in Jenkins Warnings Next Generation Plugin CVSS 3.0HIGH 8.8
- TI-2022-07276 Path traversal in Jenkins Warnings Next Generation Plugin CVSS 3.1HIGH 8.1
- TI-2019-15868 Cross-site scripting in Jenkins Warnings Next Generation Plugin CVSS 3.0MEDIUM 6.1
- TI-2019-07634 Cross-site scripting in Jenkins Warnings NG Plugin CVSS 3.0MEDIUM 5.4
- TI-2021-04706 Missing authorization in Jenkins Warnings Next Generation Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2019-10326 · CVE Program
- CVE-2019-10326 · NVD
- FIRST EPSS
- GHSA-px35-882c-47hw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences