Incorrect type conversion in Jenkins Script Security Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution, Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-704, CWE-266 and the CVSS impact.
Summary
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.61 and earlier related to the handling of type casts allowed attackers to execute arbitrary code in sandboxed scripts.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Script Security Plugin | up to 1.61 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:script-security (Maven) | before 1.62 | 1.62 | Patch available | GHSA-p56j-x44h-g66j |
- Jenkins Script Security Plugin VendorJenkins Affected up to 1.61 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.62 Fixed in 1.62 Patch available GHSA-p56j-x44h-g66j
Remediation
- Fix · GHSA-p56j-x44h-g66j org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.62 Advisory →
Red Hat 2 advisories
- RHSA-2019:2662 Released 2019-09-11 · Red Hat rating ImportantRed Hat OpenShift Container Platform 4.1 jenkins-2-plugins security update
- Red Hat OpenShift Container Platform 4.1 jenkins-2-plugins-4.1.1567707934-1.el7
- RHSA-2019:2651 Released 2019-09-04 · Red Hat rating ImportantRed Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update
- Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1566492396-1.el7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins Script Security Plugin — RHSA-2019:2651
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2019-07665 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.61 and earlier related…Priority MEDIUM 43
- Advisory ·
Jenkins Script Security Plugin — RHSA-2019:2662
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2019-07665 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.61 and earlier related…Priority MEDIUM 43
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:2651 |
| Red Hat OpenShift Container Platform 4.1 | Fixed | RHSA-2019:2662 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10355
- 2026-10-03 Alias added: GHSA-p56j-x44h-g66j
References
Advisory 5
More Jenkins Script Security vulnerabilities
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
- TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2019-10355 · CVE Program
- CVE-2019-10355 · NVD
- FIRST EPSS
- GHSA-p56j-x44h-g66j · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10355 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences