Read the docs
TI-2019-07665 Aliases CVE-2019-10356GHSA-x25x-j4w4-7m59

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.61 and earlier related…

Priority MEDIUM 43CWE-466Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.61 and earlier related to the handling of method pointer expressions allowed attackers to execute arbitrary code in sandboxed scripts.

Why it matters now

EPSS 0.02522 84th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:script-security (Maven): 1.62Red Hat: 2 advisoriesRed Hat: 2 fixed, 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Script Security Pluginup to 1.61—No fix listedCNA
—org.jenkins-ci.plugins:script-security (Maven)before 1.621.62Patch availableGHSA-x25x-j4w4-7m59
  • Jenkins Script Security Plugin VendorJenkins Affected up to 1.61 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.62 Fixed in 1.62 Patch available GHSA-x25x-j4w4-7m59

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:*up to 1.61VulnerableJenkins
cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*3.11VulnerableRed Hat
cpe:2.3:a:redhat:openshift_container_platform:4.1:*:*:*:*:*:*:*4.1VulnerableRed Hat
  • cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:* Versions up to 1.61 Vulnerable ·Jenkins
  • cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openshift_container_platform:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-x25x-j4w4-7m59 org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.62 Advisory →

Red Hat 2 advisories

  • RHSA-2019:2662 Released 2019-09-11 · Red Hat rating Important
    Red Hat OpenShift Container Platform 4.1 jenkins-2-plugins security update
    • Red Hat OpenShift Container Platform 4.1 jenkins-2-plugins-4.1.1567707934-1.el7
  • RHSA-2019:2651 Released 2019-09-04 · Red Hat rating Important
    Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update
    • Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1566492396-1.el7

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Jenkins Script Security Plugin — RHSA-2019:2651

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2019-07664 Incorrect type conversion in Jenkins Script Security PluginPriority MEDIUM 43
  • Advisory ·

    Jenkins Script Security Plugin — RHSA-2019:2662

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2019-07664 Incorrect type conversion in Jenkins Script Security PluginPriority MEDIUM 43

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.9AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.11Fixed RHSA-2019:2651
Red Hat OpenShift Container Platform 4.1Fixed RHSA-2019:2662

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10356
  2. 2026-10-03 Alias added: GHSA-x25x-j4w4-7m59

References

  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
  • TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
  • TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
See all 44 →

Sources