Contao 4.0 through 4.8.5 allows PHP local file inclusion.
Priority MEDIUM 40CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
Contao 4.0 through 4.8.5 allows PHP local file inclusion. A back end user with access to the form generator can upload arbitrary files and execute them on the server.
Why it matters now
EPSS 0.01108 66th percentileScored 2026-11-07
Fix Fixed contao/core-bundle (Packagist): 4.4.46, 4.8.6contao/contao (Packagist): 4.4.46, 4.8.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | contao/core-bundle (Packagist) | 4.0.0 to before 4.4.46 | 4.4.46 | Patch available | GHSA-wjx8-cgrm-hh8p |
| — | contao/core-bundle (Packagist) | 4.5.0 to before 4.8.6 | 4.8.6 | Patch available | GHSA-wjx8-cgrm-hh8p |
| — | contao/contao (Packagist) | 4.0.0 to before 4.4.46 | 4.4.46 | Patch available | GHSA-wjx8-cgrm-hh8p |
| — | contao/contao (Packagist) | 4.5.0 to before 4.8.6 | 4.8.6 | Patch available | GHSA-wjx8-cgrm-hh8p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.4.46 Fixed in 4.4.46 Patch available GHSA-wjx8-cgrm-hh8p
- contao/core-bundle (Packagist) Vendor— Affected 4.5.0 to before 4.8.6 Fixed in 4.8.6 Patch available GHSA-wjx8-cgrm-hh8p
- contao/contao (Packagist) Vendor— Affected 4.0.0 to before 4.4.46 Fixed in 4.4.46 Patch available GHSA-wjx8-cgrm-hh8p
- contao/contao (Packagist) Vendor— Affected 4.5.0 to before 4.8.6 Fixed in 4.8.6 Patch available GHSA-wjx8-cgrm-hh8p
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* | 4.4 – 4.4.45; 4.8 – 4.8.5 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.1:*:*:*:*:*:*:* | 4.1 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.2:*:*:*:*:*:*:* | 4.2 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.3:*:*:*:*:*:*:* | 4.3 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.5:*:*:*:*:*:*:* | 4.5 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.6:*:*:*:*:*:*:* | 4.6 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.7:*:*:*:*:*:*:* | 4.7 | Vulnerable | contao |
- cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 4.4 – 4.4.45; 4.8 – 4.8.5 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.2:*:*:*:*:*:*:* Versions 4.2 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.3:*:*:*:*:*:*:* Versions 4.3 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.5:*:*:*:*:*:*:* Versions 4.5 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.6:*:*:*:*:*:*:* Versions 4.6 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.7:*:*:*:*:*:*:* Versions 4.7 Vulnerable ·contao
Remediation
- Fix · GHSA-wjx8-cgrm-hh8p contao/core-bundle (Packagist) Fixed in 4.4.46 Advisory →
- Fix · GHSA-wjx8-cgrm-hh8p contao/core-bundle (Packagist) Fixed in 4.8.6 Advisory →
- Fix · GHSA-wjx8-cgrm-hh8p contao/contao (Packagist) Fixed in 4.4.46 Advisory →
- Fix · GHSA-wjx8-cgrm-hh8p contao/contao (Packagist) Fixed in 4.8.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-19745
- 2026-10-03 Alias added: GHSA-wjx8-cgrm-hh8p
References
Advisory 3
Other 4
- https://github.com/contao/contao/security/advisories/GHSA-wjx8-cgrm-hh8p
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2019-19745.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2019-19745.yaml
- https://github.com/contao/contao
More Contao vulnerabilities
- TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
- TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
- TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
- TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
- TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
Sources
- CVE-2019-19745 · CVE Program
- CVE-2019-19745 · NVD
- FIRST EPSS
- GHSA-wjx8-cgrm-hh8p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences