Read the docs
TI-2019-09304 Aliases CVE-2019-12463GHSA-w5r2-gvgf-mpm8

An issue was discovered in LibreNMS 1.50.1.

Priority MEDIUM 41CWE-116Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

An issue was discovered in LibreNMS 1.50.1. The scripts that handle graphing options (includes/html/graphs/common.inc.php and includes/html/graphs/graphs.inc.php) do not sufficiently validate or encode several fields of user supplied input. Some parameters are filtered with mysqli_real_escape_string, which is only useful for preventing SQL injection attacks; other parameters are unfiltered. This allows an attacker to inject RRDtool syntax with newline characters via the html/graph.php and html/graph-realtime.php scripts. RRDtool syntax is quite versatile and an attacker could leverage this to perform a number of attacks, including disclosing directory structure and filenames, disclosing file content, denial of service, or writing arbitrary files. NOTE: relative to CVE-2019-10665, this requires authentication and the pathnames differ.

Why it matters now

EPSS 0.01392 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms/librenms (Packagist): 1.53

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—librenms/librenms (Packagist)1.50.1 to before 1.531.53Patch availableGHSA-w5r2-gvgf-mpm8
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • librenms/librenms (Packagist) Vendor— Affected 1.50.1 to before 1.53 Fixed in 1.53 Patch available GHSA-w5r2-gvgf-mpm8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*1.50.1 to before 1.53Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* Versions 1.50.1 to before 1.53 Vulnerable ·librenms

Remediation

  • Fix · GHSA-w5r2-gvgf-mpm8 librenms/librenms (Packagist) Fixed in 1.53 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-12463
  2. 2026-10-03 Alias added: GHSA-w5r2-gvgf-mpm8

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources