Read the docs
TI-2019-09305 Aliases CVE-2019-12464GHSA-r336-jxfr-4c3c

An issue was discovered in LibreNMS 1.50.1.

Priority LOW 37CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

An issue was discovered in LibreNMS 1.50.1. An authenticated user can perform a directory traversal attack against the /pdf.php file with a partial filename in the report parameter, to cause local file inclusion resulting in code execution.

Why it matters now

EPSS 0.02171 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms/librenms (Packagist): 1.53

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—librenms/librenms (Packagist)before 1.531.53Patch availableGHSA-r336-jxfr-4c3c
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • librenms/librenms (Packagist) Vendor— Affected before 1.53 Fixed in 1.53 Patch available GHSA-r336-jxfr-4c3c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:1.50.1:*:*:*:*:*:*:*1.50.1Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:1.50.1:*:*:*:*:*:*:* Versions 1.50.1 Vulnerable ·librenms

Remediation

  • Fix · GHSA-r336-jxfr-4c3c librenms/librenms (Packagist) Fixed in 1.53 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-12464
  2. 2026-10-03 Alias added: GHSA-r336-jxfr-4c3c

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources