WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site…
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site request forgery (CSRF) issue with resultant stored cross-site scripting (XSS) via includes/admin/importers/class-wc-product-csv-importer-controller.php.
Why it matters now
EPSS 0.00534 45th percentileScored 2026-11-07
Fix Fixed woocommerce/woocommerce (Packagist): 3.6.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | woocommerce/woocommerce (Packagist) | before 3.6.5 | 3.6.5 | Patch available | GHSA-rcmf-88p4-9wrg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- woocommerce/woocommerce (Packagist) Vendor— Affected before 3.6.5 Fixed in 3.6.5 Patch available GHSA-rcmf-88p4-9wrg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* | before 3.6.5 | Vulnerable | WooCommerce |
- cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* Versions before 3.6.5 Vulnerable ·WooCommerce
Remediation
- Fix · GHSA-rcmf-88p4-9wrg woocommerce/woocommerce (Packagist) Fixed in 3.6.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-20891
- 2026-10-03 Alias added: GHSA-rcmf-88p4-9wrg
References
Advisory 3
More Woocommerce vulnerabilities
- TI-2022-00684 WooCommerce < 6.2.1 - Subscriber+ Arbitrary Comment Deletion CVSS 3.1MEDIUM 4.3
- TI-2017-13530 In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible… CVSS 3.0HIGH 8.8
- TI-2018-14697 The logging system of the Automattic WooCommerce plugin before 3.4.6 for WordPress is… CVSS 3.0HIGH 8.1
- TI-2023-28650 WordPress WooCommerce Plugin <= 8.2.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-09228 WooCommerce <= 9.0.2 - Unauthenticated HTML Injection CVSS 3.1MEDIUM 6.1
- TI-2020-17581 The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2019-20891 · CVE Program
- CVE-2019-20891 · NVD
- FIRST EPSS
- GHSA-rcmf-88p4-9wrg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences