Read the docs
TI-2022-00684 Aliases CVE-2022-0775GHSA-hw3h-gc2r-whp8

WooCommerce < 6.2.1 - Subscriber+ Arbitrary Comment Deletion

Priority MEDIUM 53CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.

Summary

The WooCommerce WordPress plugin before 6.2.1 does not have proper authorisation check when deleting reviews, which could allow any authenticated users, such as subscriber to delete arbitrary comment

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00675 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WooCommerce (Unknown): 6.2.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWooCommercebefore 6.2.16.2.1Patch availableCNA
  • WooCommerce VendorUnknown Affected before 6.2.1 Fixed in 6.2.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:*before 6.2.1VulnerableWooCommerce
  • cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* Versions before 6.2.1 Vulnerable ·WooCommerce

Remediation

  • Fix · CNA WooCommerce (Unknown) Fixed in 6.2.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0775
  2. 2026-10-03 Alias added: GHSA-hw3h-gc2r-whp8

References

  • TI-2017-13530 In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible… CVSS 3.0HIGH 8.8
  • TI-2019-15109 WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site… CVSS 3.1HIGH 8.8
  • TI-2018-14697 The logging system of the Automattic WooCommerce plugin before 3.4.6 for WordPress is… CVSS 3.0HIGH 8.1
  • TI-2023-28650 WordPress WooCommerce Plugin <= 8.2.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-09228 WooCommerce <= 9.0.2 - Unauthenticated HTML Injection CVSS 3.1MEDIUM 6.1
  • TI-2020-17581 The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the… CVSS 3.1MEDIUM 5.3
See all 15 →

Sources