The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the…
Priority LOW 31CWE-639Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the status of arbitrary orders via the order_id parameter in a fetch_order_status action.
Why it matters now
EPSS 0.04026 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed woocommerce/woocommerce (Packagist): 4.7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | woocommerce/woocommerce (Packagist) | before 4.7.0 | 4.7.0 | Patch available | GHSA-wwh8-v3j3-gxfw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- woocommerce/woocommerce (Packagist) Vendor— Affected before 4.7.0 Fixed in 4.7.0 Patch available GHSA-wwh8-v3j3-gxfw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* | before 4.7.0 | Vulnerable | WooCommerce |
- cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* Versions before 4.7.0 Vulnerable ·WooCommerce
Remediation
- Fix · GHSA-wwh8-v3j3-gxfw woocommerce/woocommerce (Packagist) Fixed in 4.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-29156
- 2026-10-03 Alias added: GHSA-wwh8-v3j3-gxfw
References
More Woocommerce vulnerabilities
- TI-2022-00684 WooCommerce < 6.2.1 - Subscriber+ Arbitrary Comment Deletion CVSS 3.1MEDIUM 4.3
- TI-2017-13530 In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible… CVSS 3.0HIGH 8.8
- TI-2019-15109 WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site… CVSS 3.1HIGH 8.8
- TI-2018-14697 The logging system of the Automattic WooCommerce plugin before 3.4.6 for WordPress is… CVSS 3.0HIGH 8.1
- TI-2023-28650 WordPress WooCommerce Plugin <= 8.2.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-09228 WooCommerce <= 9.0.2 - Unauthenticated HTML Injection CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-29156 · CVE Program
- CVE-2020-29156 · NVD
- FIRST EPSS
- GHSA-wwh8-v3j3-gxfw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences