Priority MEDIUM 53
The WooCommerce WordPress plugin before 6.2.1 does not have proper authorisation check when deleting reviews, which could allow any authenticated users, such as subscriber to delete arbitrary comment
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00675 · Published 2024-01-16 · Fixed in 6.2.1 CWE-863
Priority MEDIUM 42
In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible after gaining access to the target site with a user account that has at least Shop manager privileges.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01961 · Published 2019-01-15 · No fix listed CWE-94
Priority LOW 39
WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site request forgery (CSRF) issue with resultant stored cross-site scripting (XSS) via includes/admin/importers/class-wc-product-csv-importer…
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00534 · Published 2020-06-19 · Fixed in 3.6.5 CWE-352
Priority LOW 39
The logging system of the Automattic WooCommerce plugin before 3.4.6 for WordPress is vulnerable to a File Deletion vulnerability.
CVSS 3.0HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.01842 · Published 2019-01-15 · No fix listed CWE-22
Priority LOW 38
Cross-Site Request Forgery (CSRF) vulnerability in Automattic WooCommerce.This issue affects WooCommerce: from n/a through 8.2.2.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00287 · Published 2024-01-08 · No fix listed CWE-352
Priority LOW 34
The WooCommerce plugin for WordPress is vulnerable to HTML Injection in all versions up to, and including, 9.0.2.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00594 · Published 2024-10-15 · No fix listed CWE-79
Priority LOW 31
The WooCommerce plugin before 4.7.0 for WordPress allows remote attackers to view the status of arbitrary orders via the order_id parameter in a fetch_order_status action.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.04026 · Published 2020-12-27 · Fixed in 4.7.0 CWE-639
Priority LOW 30
Cross-site scripting (XSS) vulnerability in the WooCommerce plugin before 2.3.6 for WordPress allows remote attackers to inject arbitrary web script or HTML via a crafted order.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01154 · Published 2018-02-08 · No fix listed CWE-79
Priority LOW 29
WooCommerce before 3.5.5 allows XSS via a Photoswipe caption.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00983 · Published 2019-02-26 · No fix listed CWE-79
Priority LOW 28
The WooCommerce plugin for WordPress is vulnerable to PostMessage-Based Cross-Site Scripting via the 'customize-store' page in all versions up to, and including, 9.4.2 due to insufficient input sanitization and output es…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00457 · Published 2025-05-22 · No fix listed CWE-79
Priority LOW 27
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in PI Websolution Product page shipping calculator for WooCommerce plugin <= 1.3.25 versions.
CVSS 3.1MEDIUM 5.9· Network · High privileges · User interaction · EPSS 0.00396 · Published 2023-08-25 · No fix listed CWE-79
Priority LOW 25
WooCommerce is an open-source e-commerce platform built on WordPress.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00483 · Published 2024-06-12 · Fixed in 8.8.5, 8.9.3 CWE-79
Priority LOW 25
Woocommerce is an open source eCommerce plugin for WordPress.
CVSS 3.1MEDIUM 4.9· Network · High privileges · No interaction · EPSS 0.01265 · Published 2021-07-26 · Fixed in 3.3.6 CWE-89
Priority LOW 24
Cross-site scripting (XSS) vulnerability in the WooCommerce plugin before 2.6.9 for WordPress allows remote authenticated administrators to inject arbitrary web script or HTML by providing crafted tax-rate table values i…
CVSS 3.0MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00901 · Published 2017-01-04 · No fix listed CWE-79
Priority LOW 23
The WooCommerce WordPress plugin before 6.6.0 is vulnerable to stored HTML injection due to lack of escaping and sanitizing in the payment gateway titles
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00667 · Published 2022-07-17 · Fixed in 6.6.0 CWE-116
Priority LOW 23
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00743 · Published 2021-05-17 · Fixed in 5.2.0 CWE-79