Read the docs
TI-2020-01680 Aliases CVE-2020-1736GHSA-x7jh-595q-wq82

Incorrect permission assignment in Red Hat ansible

Priority LOW 16CWE-732Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 4 fixed, 5 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

A flaw was found in Ansible Engine when a file is moved using atomic_move primitive as the file mode cannot be specified. This sets the destination files world-readable if the destination file does not exist and if the file exists, the file could be changed to have less restrictive permissions before the move. This could lead to the disclosure of sensitive data. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

Why it matters now

EPSS 0.00401 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial Red Hat: 1 advisoryRed Hat: 4 fixed, 5 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red Hatansible2.7.x, 2.8.x, 2.9.x—No fix listedCNA
—ansible (PyPI)2.7.0 – 2.10.0—No fix listedGHSA-x7jh-595q-wq82
  • ansible VendorRed Hat Affected 2.7.x, 2.8.x, 2.9.x Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected 2.7.0 – 2.10.0 Fixed in — No fix listed GHSA-x7jh-595q-wq82

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*up to 2.7.16; 2.8.0 to before 2.8.15; 2.9.0 to before 2.9.13VulnerableRed Hat
cpe:2.3:a:redhat:ansible_tower:*:*:*:*:*:*:*:*up to 3.3.4; 3.3.5 – 3.4.5; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3; 3.7.0 – 3.7.2VulnerableRed Hat
cpe:2.3:a:redhat:cloudforms_management_engine:5.0:*:*:*:*:*:*:*5.0VulnerableRed Hat
cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:*13VulnerableRed Hat
cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*31VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*32VulnerableFedoraproject
  • cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions up to 2.7.16; 2.8.0 to before 2.8.15; 2.9.0 to before 2.9.13 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:ansible_tower:*:*:*:*:*:*:*:* Versions up to 3.3.4; 3.3.5 – 3.4.5; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3; 3.7.0 – 3.7.2 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:cloudforms_management_engine:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:* Versions 13 Vulnerable ·Red Hat
  • cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject

Remediation

Red Hat 1 advisory

  • RHSA-2020:3600 Released 2020-09-01 · Red Hat rating Important
    Ansible security and bug fix update (2.8.15)
    • Red Hat Ansible Engine 2.8 for RHEL 7 Server ansible-2.8.15-1.el7ae
    • Red Hat Ansible Engine 2.8 for RHEL 8 ansible-2.8.15-1.el8ae

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ceph Storage 2AffectedNo fix planned: Out of support scope
Red Hat Ceph Storage 3AffectedNo fix yet: Fix deferred
Red Hat OpenStack Platform 10 (Newton)AffectedNo fix planned: Out of support scope
Red Hat OpenStack Platform 13 (Queens)AffectedNo fix planned: Will not fix
Red Hat Storage 3AffectedNo fix planned: Will not fix
Red Hat Ansible Engine 2.8 for RHEL 7 ServerFixed RHSA-2020:3600
Red Hat Ansible Engine 2.8 for RHEL 8Fixed RHSA-2020:3600
Red Hat Ansible Tower 3.4 for RHEL 7 ServerFixed—
Red Hat Ansible Tower 3.5 for RHEL 7 ServerFixed—
Not affected: 1 product
  • CloudForms Management Engine 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-1736
  2. 2026-10-03 Alias added: GHSA-x7jh-595q-wq82

References

  • TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
  • TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
  • TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
  • TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
See all 44 →

Sources