Read the docs
TI-2020-08642 Aliases CVE-2020-10744GHSA-vp9j-rghq-8jhh

Race condition in Red Hat ansible

Priority LOW 22CWE-377Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
Required
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Partial Red Hat: 7 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.

Summary

An incomplete fix was found for the fix of the flaw CVE-2020-1733 ansible: insecure temporary directory when running become_user from become directive. The provided fix is insufficient to prevent the race condition on systems using ACLs and FUSE filesystems. Ansible Engine 2.7.18, 2.8.12, and 2.9.9 as well as previous versions are affected and Ansible Tower 3.4.5, 3.5.6 and 3.6.4 as well as previous versions are affected.

Why it matters now

EPSS 0.00255 17th percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.10.0rc1, 2.9.12Red Hat: 7 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red Hatansibleansible-engine 2.7.18 and prior; ansible-engine 2.8.12 and prior; ansible-engine 2.9.9 and prior; ansible-tower 3.4.5 and prior; ansible-tower 3.5.6 and prior; ansible-tower 3.6.4 and prior—No fix listedCNA
—ansible (PyPI)2.10.0a1 to before 2.10.0rc12.10.0rc1Patch availableGHSA-vp9j-rghq-8jhh
—ansible (PyPI)before 2.9.122.9.12Patch availableGHSA-vp9j-rghq-8jhh
  • ansible VendorRed Hat Affected ansible-engine 2.7.18 and prior; ansible-engine 2.8.12 and prior; ansible-engine 2.9.9 and prior; ansible-tower 3.4.5 and prior; ansible-tower 3.5.6 and prior; ansible-tower 3.6.4 and prior Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected 2.10.0a1 to before 2.10.0rc1 Fixed in 2.10.0rc1 Patch available GHSA-vp9j-rghq-8jhh
  • ansible (PyPI) Vendor— Affected before 2.9.12 Fixed in 2.9.12 Patch available GHSA-vp9j-rghq-8jhh

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*2.7.0 – 2.7.18; 2.8.0 – 2.8.12; 2.9.0 – 2.9.9VulnerableRed Hat
cpe:2.3:a:redhat:ansible_tower:*:*:*:*:*:*:*:*3.4.0 – 3.4.5; 3.5.0 – 3.5.6; 3.6.0 – 3.6.4VulnerableRed Hat
  • cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions 2.7.0 – 2.7.18; 2.8.0 – 2.8.12; 2.9.0 – 2.9.9 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:ansible_tower:*:*:*:*:*:*:*:* Versions 3.4.0 – 3.4.5; 3.5.0 – 3.5.6; 3.6.0 – 3.6.4 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-vp9j-rghq-8jhh ansible (PyPI) Fixed in 2.10.0rc1 Advisory →
  • Fix · GHSA-vp9j-rghq-8jhh ansible (PyPI) Fixed in 2.9.12 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ansible Engine 2AffectedNo fix yet
Red Hat Ansible Tower 3AffectedNo fix planned: Out of support scope
Red Hat Ceph Storage 2AffectedNo fix planned: Out of support scope
Red Hat Ceph Storage 3AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 10 (Newton)AffectedNo fix planned: Out of support scope
Red Hat OpenStack Platform 13 (Queens)AffectedNo fix planned: Will not fix
Red Hat Storage 3AffectedNo fix planned: Will not fix

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-10744
  2. 2026-10-03 Alias added: GHSA-vp9j-rghq-8jhh

References

  • TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
  • TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
  • TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
  • TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
See all 44 →

Sources