Cross-site scripting in Atlassian Confluence Server
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Affected versions of Atlassian Confluence Server and Data Center allow remote attackers to inject arbitrary HTML or JavaScript via a Cross-Site Scripting (XSS) vulnerability in user macro parameters. The affected versions are before version 7.4.2, and from version 7.5.0 before 7.5.2.
Why it matters now
EPSS 0.01154 67th percentileScored 2026-11-07
Fix Fixed Confluence Server (Atlassian): 7.4.2, 7.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Server | before 7.4.2; 7.5.0 and later; before 7.5.2 | 7.4.2, 7.5.2 | Patch available | CNA |
- Confluence Server VendorAtlassian Affected before 7.4.2; 7.5.0 and later; before 7.5.2 Fixed in 7.4.2, 7.5.2 Patch available CNA
Remediation
- Fix · CNA Confluence Server (Atlassian) Fixed in 7.4.2, 7.5.2
Timeline
- 2026-10-02 Threatist record created from CVE-2020-14175
- 2026-10-03 Alias added: GHSA-fxvf-vgj9-gphr
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-14175 · CVE Program
- CVE-2020-14175 · NVD
- FIRST EPSS
- GHSA-fxvf-vgj9-gphr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences