An issue was discovered in LibreNMS before 1.65.1.
Priority MEDIUM 42CWE-668Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
An issue was discovered in LibreNMS before 1.65.1. It has insufficient access control for normal users because of "'guard' => 'admin'" instead of "'middleware' => ['can:admin']" in routes/web.php.
Why it matters now
EPSS 0.01918 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms/librenms (Packagist): 1.65.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | librenms/librenms (Packagist) | before 1.65.1 | 1.65.1 | Patch available | GHSA-3c33-3465-fhx2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- librenms/librenms (Packagist) Vendor— Affected before 1.65.1 Fixed in 1.65.1 Patch available GHSA-3c33-3465-fhx2
Remediation
- Fix · GHSA-3c33-3465-fhx2 librenms/librenms (Packagist) Fixed in 1.65.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15877
- 2026-10-03 Alias added: GHSA-3c33-3465-fhx2
References
Exploit 1
Patch 2
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2020-15877 · CVE Program
- CVE-2020-15877 · NVD
- FIRST EPSS
- GHSA-3c33-3465-fhx2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences