SQL injection in Gallagher Command Centre
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
SQL Injection vulnerability in Enterprise Data Interface of Gallagher Command Centre allows a remote attacker with 'Edit Enterprise Data Interfaces' privilege to execute arbitrary SQL against a third party database if EDI is configured to import data from this database. This issue affects: Gallagher Command Centre 8.30 versions prior to 8.30.1236(MR1); 8.20 versions prior to 8.20.1166(MR3); 8.10 versions prior to 8.10.1211(MR5); 8.00 versions prior to 8.00.1228(MR6); version 7.90 and prior versions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Gallagher | Command Centre | up to 7.90; 8.30 to before 8.30.1236(MR1); 8.20 to before 8.20.1166(MR3); 8.10 to before 8.10.1211(MR5); 8.00 to before 8.00.1228(MR6) | 8.30.1236(MR1), 8.20.1166(MR3), 8.10.1211(MR5), 8.00.1228(MR6) | Patch available | CNA |
- Command Centre VendorGallagher Affected up to 7.90; 8.30 to before 8.30.1236(MR1); 8.20 to before 8.20.1166(MR3); 8.10 to before 8.10.1211(MR5); 8.00 to before 8.00.1228(MR6) Fixed in 8.30.1236(MR1), 8.20.1166(MR3), 8.10.1211(MR5), 8.00.1228(MR6) Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* | before 7.90.0; 8.00 to before 8.00.1228; 8.10 to before 8.10.1211; 8.20 to before 8.20.1166; 8.30 to before 8.30.1236 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.00.1228:-:*:*:*:*:*:* | 8.00.1228 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.00.1228:maintenance_release6:*:*:*:*:*:* | 8.00.1228 maintenance_release6 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.10.1211:-:*:*:*:*:*:* | 8.10.1211 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.10.1211:maintenance_release5:*:*:*:*:*:* | 8.10.1211 maintenance_release5 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.20.1166:-:*:*:*:*:*:* | 8.20.1166 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.20.1166:maintenance_release3:*:*:*:*:*:* | 8.20.1166 maintenance_release3 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.30.1236:-:*:*:*:*:*:* | 8.30.1236 | Vulnerable | Gallagher |
| cpe:2.3:a:gallagher:command_centre:8.30.1236:maintenance_release1:*:*:*:*:*:* | 8.30.1236 maintenance_release1 | Vulnerable | Gallagher |
- cpe:2.3:a:gallagher:command_centre:*:*:*:*:*:*:*:* Versions before 7.90.0; 8.00 to before 8.00.1228; 8.10 to before 8.10.1211; 8.20 to before 8.20.1166; 8.30 to before 8.30.1236 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.00.1228:-:*:*:*:*:*:* Versions 8.00.1228 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.00.1228:maintenance_release6:*:*:*:*:*:* Versions 8.00.1228 maintenance_release6 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.10.1211:-:*:*:*:*:*:* Versions 8.10.1211 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.10.1211:maintenance_release5:*:*:*:*:*:* Versions 8.10.1211 maintenance_release5 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.20.1166:-:*:*:*:*:*:* Versions 8.20.1166 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.20.1166:maintenance_release3:*:*:*:*:*:* Versions 8.20.1166 maintenance_release3 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.30.1236:-:*:*:*:*:*:* Versions 8.30.1236 Vulnerable ·Gallagher
- cpe:2.3:a:gallagher:command_centre:8.30.1236:maintenance_release1:*:*:*:*:*:* Versions 8.30.1236 maintenance_release1 Vulnerable ·Gallagher
Remediation
- Fix · CNA Command Centre (Gallagher) Fixed in 8.30.1236(MR1), 8.20.1166(MR3), 8.10.1211(MR5), 8.00.1228(MR6)
Timeline
- 2026-10-02 Threatist record created from CVE-2020-16104
- 2026-10-03 Alias added: GHSA-w3xv-vqgp-pqp7
References
More Gallagher Command Centre vulnerabilities
- TI-2021-05931 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2020-12668 Improper authentication in Gallagher Command Centre CVSS 3.1CRITICAL 9.8
- TI-2020-12666 Improper authorization in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2019-11404 An issue was discovered in Gallagher Command Centre 8.10 before 8.10.1092(MR2). CVSS 3.0CRITICAL 9.8
- TI-2021-05986 SQL injection in Gallagher Command Centre CVSS 3.1CRITICAL 9.9
- TI-2020-12673 Incorrect type conversion in Gallagher Command Centre CVSS 3.1HIGH 8.8
Sources
- CVE-2020-16104 · CVE Program
- CVE-2020-16104 · NVD
- FIRST EPSS
- GHSA-w3xv-vqgp-pqp7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences