A flaw was found in Ansible Base when using the aws_ssm connection plugin as garbage…
Priority LOW 25CWE-212Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A flaw was found in Ansible Base when using the aws_ssm connection plugin as garbage collector is not happening after playbook run is completed. Files would remain in the bucket exposing the data. This issue affects directly data confidentiality.
Why it matters now
EPSS 0.00319 24th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 2.10.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS Community | Community Collections | from 1.0.0 to 1.2.0 | — | No fix listed | CNA |
| — | ansible (PyPI) | before 2.10.1 | 2.10.1 | Patch available | GHSA-f556-49jc-4rvc |
- Community Collections VendorAWS Community Affected from 1.0.0 to 1.2.0 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 2.10.1 Fixed in 2.10.1 Patch available GHSA-f556-49jc-4rvc
Remediation
- Fix · GHSA-f556-49jc-4rvc ansible (PyPI) Fixed in 2.10.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-25635
- 2026-10-03 Alias added: GHSA-f556-49jc-4rvc
References
Advisory 3
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-25635 · CVE Program
- CVE-2020-25635 · NVD
- FIRST EPSS
- GHSA-f556-49jc-4rvc · GitHub Advisory Database · CC BY 4.0
- CVE-2020-25635 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences