Read the docs
TI-2020-18588 Aliases CVE-2020-36290GHSA-9r83-5mrw-rhhq

Cross-site scripting in Atlassian Confluence Server

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Livesearch macro in Confluence Server and Data Center before version 7.4.5, from version 7.5.0 before 7.6.3, and from version 7.7.0 before version 7.7.4 allows remote attackers with permission to edit a page or blog to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability in the page excerpt functionality.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00697 53rd percentileScored 2026-11-07
Fix Fixed Confluence Server (Atlassian): 7.4.5, 7.6.3, 7.7.4Confluence Data Center (Atlassian): 7.4.5, 7.6.3, 7.7.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AtlassianConfluence Serverbefore 7.4.5; 7.5.0 and later; before 7.6.3; 7.7.0 and later; before 7.7.47.4.5, 7.6.3, 7.7.4Patch availableCNA
AtlassianConfluence Data Centerbefore 7.4.5; 7.5.0 and later; before 7.6.3; 7.7.0 and later; before 7.7.47.4.5, 7.6.3, 7.7.4Patch availableCNA
  • Confluence Server VendorAtlassian Affected before 7.4.5; 7.5.0 and later; before 7.6.3; 7.7.0 and later; before 7.7.4 Fixed in 7.4.5, 7.6.3, 7.7.4 Patch available CNA
  • Confluence Data Center VendorAtlassian Affected before 7.4.5; 7.5.0 and later; before 7.6.3; 7.7.0 and later; before 7.7.4 Fixed in 7.4.5, 7.6.3, 7.7.4 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:*before 7.4.5; 7.5.0 to before 7.6.3; 7.7.0 to before 7.7.4VulnerableAtlassian
cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*before 7.4.5; 7.5.0 to before 7.6.3; 7.7.0 to before 7.7.4VulnerableAtlassian
  • cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions before 7.4.5; 7.5.0 to before 7.6.3; 7.7.0 to before 7.7.4 Vulnerable ·Atlassian
  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions before 7.4.5; 7.5.0 to before 7.6.3; 7.7.0 to before 7.7.4 Vulnerable ·Atlassian

Remediation

  • Fix · CNA Confluence Server (Atlassian) Fixed in 7.4.5, 7.6.3, 7.7.4
  • Fix · CNA Confluence Data Center (Atlassian) Fixed in 7.4.5, 7.6.3, 7.7.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-36290
  2. 2026-10-03 Alias added: GHSA-9r83-5mrw-rhhq

References

  • TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
  • TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
See all 38 →

Sources