Sensitive information in log files in Ansible
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 7 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-532.
Summary
A flaw was found in ansible module where credentials are disclosed in the console log by default and not protected by the security feature when using the bitbucket_pipeline_variable module. This flaw allows an attacker to steal bitbucket_pipeline credentials. The highest threat from this vulnerability is to confidentiality.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Ansible | Fixed in ansible 2.9.18 | — | No fix listed | CNA |
| — | ansible (PyPI) | 2.8.0a1 to before 2.8.19 | 2.8.19 | Patch available | GHSA-fh5v-5f35-2rv2 |
| — | ansible (PyPI) | 2.9.0b1 to before 2.9.18 | 2.9.18 | Patch available | GHSA-fh5v-5f35-2rv2 |
- Ansible Vendor— Affected Fixed in ansible 2.9.18 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected 2.8.0a1 to before 2.8.19 Fixed in 2.8.19 Patch available GHSA-fh5v-5f35-2rv2
- ansible (PyPI) Vendor— Affected 2.9.0b1 to before 2.9.18 Fixed in 2.9.18 Patch available GHSA-fh5v-5f35-2rv2
Remediation
- Fix · GHSA-fh5v-5f35-2rv2 ansible (PyPI) Fixed in 2.8.19 Advisory →
- Fix · GHSA-fh5v-5f35-2rv2 ansible (PyPI) Fixed in 2.9.18 Advisory →
Red Hat 4 advisories
- RHSA-2021:2180 Released 2021-06-01 · Red Hat rating ModerateRHV Engine and Host Common Packages security update [ovirt-4.4.6]
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 ansible-2.9.18-1.el8ae
- Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts ansible-2.9.18-1.el8ae
- RHSA-2021:1079 Released 2021-04-09 · Red Hat rating ModerateRed Hat Ansible Automation Platform Operator 1.2 security update
- Red Hat Ansible Automation Platform 1.2 for RHEL 7 ansible-automation-platform/platform-resource-operator-bundle, ansible-automation-platform/platform-resource-rhel7-operator, ansible-automation-platform/platform-resource-runner-rhel7
- RHSA-2021:0663 Released 2021-02-24 · Red Hat rating ModerateAnsible security and bug fix update (2.9.18)
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.9.18-1.el7ae, ansible-test-2.9.18-1.el7ae
- Red Hat Ansible Engine 2 for RHEL 8 ansible-2.9.18-1.el8ae, ansible-test-2.9.18-1.el8ae
Show 1 more Red Hat advisories
- RHSA-2021:0664 Released 2021-02-24 · Red Hat rating ModerateAnsible security and bug fix update (2.9.18)
- Red Hat Ansible Engine 2.9 for RHEL 7 Server ansible-2.9.18-1.el7ae, ansible-test-2.9.18-1.el7ae
- Red Hat Ansible Engine 2.9 for RHEL 8 ansible-2.9.18-1.el8ae, ansible-test-2.9.18-1.el8ae
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Tower 3 | Affected | No fix planned: Out of support scope |
| RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 | Fixed | RHSA-2021:2180 |
| Red Hat Ansible Automation Platform 1.2 for RHEL 7 | Fixed | RHSA-2021:1079 |
| Red Hat Ansible Engine 2 for RHEL 7 | Fixed | RHSA-2021:0663 |
| Red Hat Ansible Engine 2 for RHEL 8 | Fixed | RHSA-2021:0663 |
| Red Hat Ansible Engine 2.9 for RHEL 7 Server | Fixed | RHSA-2021:0664 |
| Red Hat Ansible Engine 2.9 for RHEL 8 | Fixed | RHSA-2021:0664 |
| Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts | Fixed | RHSA-2021:2180 |
Not affected: 4 products
- RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4
- Red Hat Storage 3
- Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts
- Red Hat Virtualization 4 Tools for Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-20180
- 2026-10-03 Alias added: GHSA-fh5v-5f35-2rv2
References
Advisory 2
Other 7
- https://github.com/ansible/ansible/pull/73242
- https://github.com/ansible/ansible/pull/73243
- https://github.com/ansible/ansible
- https://github.com/ansible/ansible/blob/v2.8.19/changelogs/CHANGELOG-v2.8.rst
- https://github.com/ansible/ansible/blob/v2.9.18/changelogs/CHANGELOG-v2.9.rst
- https://github.com/ansible/ansible/tree/v2.7.18/lib/ansible/modules/source_control
- https://github.com/ansible/ansible/tree/v2.8.0a1/lib/ansible/modules/source_control
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-20180 · CVE Program
- CVE-2021-20180 · NVD
- FIRST EPSS
- GHSA-fh5v-5f35-2rv2 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-20180 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences