Read the docs
TI-2021-06444 Aliases CVE-2021-24152GHSA-jqrr-p4p9-3jf4

Popup Builder < 3.74 - Authenticated Reflected Cross-Site Scripting (XSS)

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The "All Subscribers" setting page of Popup Builder was vulnerable to reflected Cross-Site Scripting.

Why it matters now

EPSS 0.00734 54th percentileScored 2026-11-07
Fix Fixed Popup Builder – Responsive WordPress Pop up – Subscription & Newsletter (Unknown): 3.74

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPopup Builder – Responsive WordPress Pop up – Subscription & Newsletter3.74 to before 3.743.74Patch availableCNA
  • Popup Builder – Responsive WordPress Pop up – Subscription & Newsletter VendorUnknown Affected 3.74 to before 3.74 Fixed in 3.74 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:*before 3.74Vulnerablepopupbuilder
  • cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:* Versions before 3.74 Vulnerable ·popupbuilder

Remediation

  • Fix · CNA Popup Builder – Responsive WordPress Pop up – Subscription & Newsletter (Unknown) Fixed in 3.74

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24152
  2. 2026-10-03 Alias added: GHSA-jqrr-p4p9-3jf4

References

  • TI-2022-00402 Popup Builder < 4.1.1 - SQL Injection to Reflected Cross-Site Scripting CVSS 3.1CRITICAL 9.8
  • TI-2023-05777 popup-builder < 4.2.6 - Admin+ SSRF & File Read CVSS 3.1HIGH 7.5
  • TI-2024-08748 Popup Builder < 4.3.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2020-07226 The Popup Builder plugin 2.2.8 through 2.6.7.6 for WordPress is vulnerable to SQL… CVSS 3.1CRITICAL 9.8
  • TI-2019-10917 A SQL injection vulnerability exists in the Sygnoos Popup Builder plugin before 3.45 for… CVSS 3.1CRITICAL 9.8
  • TI-2021-07360 Popup Builder < 4.0.7 - LFI to RCE CVSS 3.1HIGH 8.8
See all 17 →

Sources