Elementor < 3.1.2 - Authenticated Stored Cross-Site Scripting (XSS) in Divider Widget
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
In the Elementor Website Builder WordPress plugin before 3.1.4, the divider widget (includes/widgets/divider.php) accepts an ‘html_tag’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request with this parameter set to ‘script’ and combined with a ‘text’ parameter containing JavaScript, which will then be executed when the saved page is viewed or previewed.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Elementor Website Builder | 3.1.4 to before 3.1.4 | 3.1.4 | Patch available | CNA |
- Elementor Website Builder VendorUnknown Affected 3.1.4 to before 3.1.4 Fixed in 3.1.4 Patch available CNA
Remediation
- Fix · CNA Elementor Website Builder (Unknown) Fixed in 3.1.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Elementor Website Builder 3.1.4
6 records Highest priority Priority LOW 6 LOW
Other records, highest priority first
- TI-2021-06498 Elementor < 3.1.2 - Authenticated Stored Cross-Site Scripting (XSS) in Image Box WidgetPriority LOW 26
- TI-2021-06497 Elementor < 3.1.2 - Authenticated Stored Cross-Site Scripting (XSS) in Icon Box WidgetPriority LOW 26
- TI-2021-06496 Elementor < 3.1.2 - Authenticated Stored Cross-Site Scripting (XSS) in Accordion WidgetPriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24203
- 2026-10-03 Alias added: GHSA-66w3-q6c3-mx37
References
More Elementor Website Builder vulnerabilities
- TI-2022-01211 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution CVSS 3.1HIGH 8.8
- TI-2023-00313 Elementor Website Builder < 3.12.2 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2023-25675 WordPress Elementor plugin <= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-26607 WordPress Elementor plugin 3.3.0-3.18.1 - Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.9
- TI-2023-25676 WordPress Elementor Website Builder Plugin <= 3.16.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2021-07171 Elementor < 3.4.8 - DOM Cross-Site-Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-24203 · CVE Program
- CVE-2021-24203 · NVD
- FIRST EPSS
- GHSA-66w3-q6c3-mx37 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences