Woocommerce < 5.2.0 - Authenticated Stored Cross-Site Scripting (XSS)
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
Why it matters now
EPSS 0.00743 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WooCommerce (Automattic): 5.2.0woocommerce/woocommerce (Packagist): 5.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Automattic | WooCommerce | 5.2.0 to before 5.2.0 | 5.2.0 | Patch available | CNA |
| — | woocommerce/woocommerce (Packagist) | before 5.2.0 | 5.2.0 | Patch available | GHSA-mp46-7x6q-f28m |
- WooCommerce VendorAutomattic Affected 5.2.0 to before 5.2.0 Fixed in 5.2.0 Patch available CNA
- woocommerce/woocommerce (Packagist) Vendor— Affected before 5.2.0 Fixed in 5.2.0 Patch available GHSA-mp46-7x6q-f28m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* | before 5.2.0 | Vulnerable | WooCommerce |
- cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* Versions before 5.2.0 Vulnerable ·WooCommerce
Remediation
- Fix · CNA WooCommerce (Automattic) Fixed in 5.2.0
- Fix · GHSA-mp46-7x6q-f28m woocommerce/woocommerce (Packagist) Fixed in 5.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24323
- 2026-10-03 Alias added: GHSA-mp46-7x6q-f28m
References
More Automattic vulnerabilities
- TI-2023-12700 Improper authentication in WooCommerce Payments WordPress Plugin CVSS 3.1CRITICAL 9.8
- TI-2023-03453 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2024-06106 Jetpack Boost < 3.4.7 - Admin+ SSRF CVSS 3.1CRITICAL 9.1
- TI-2013-01782 WordPress W3 Total Cache Plugin 0.9.2.8 has a Remote PHP Code Execution Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-02368 Prototype Pollution in automattic/mongoose CVSS 3.1CRITICAL 9.8
- TI-2023-02806 Jetpack < 12.1.1 - Author+ Arbitrary File Manipulation via API CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24323 · CVE Program
- CVE-2021-24323 · NVD
- FIRST EPSS
- GHSA-mp46-7x6q-f28m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences