WP JobSearch < 1.7.4 - Authenticated Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP JobSearch WordPress plugin before 1.7.4 did not sanitise or escape multiple of its parameters from the my-resume page before outputting them in the page, allowing low privilege users to use JavaScript payloads in them and leading to a Stored Cross-Site Scripting issue
Why it matters now
EPSS 0.00633 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP JobSearch (Unknown): 1.7.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP JobSearch | 1.7.4 to before 1.7.4 | 1.7.4 | Patch available | CNA |
- WP JobSearch VendorUnknown Affected 1.7.4 to before 1.7.4 Fixed in 1.7.4 Patch available CNA
Remediation
- Fix · CNA WP JobSearch (Unknown) Fixed in 1.7.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24421
- 2026-10-03 Alias added: GHSA-q4j4-vw28-779r
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More eyecix Jobsearch Wp Job Board vulnerabilities
- TI-2023-06036 JobSearch WP Job Board < 2.3.4 - Arbitrary File Upload to RCE CVSS 3.1HIGH 7.5
- TI-2024-07991 WP JobSearch <= 2.6.7 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 10.0
- TI-2024-07990 WP JobSearch <= 2.6.7 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1CRITICAL 9.9
- TI-2024-29520 WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.3 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-29518 WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.4 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-31915 WordPress WP JobSearch plugin <= 2.5.9 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-24421 · CVE Program
- CVE-2021-24421 · NVD
- FIRST EPSS
- GHSA-q4j4-vw28-779r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences