Post Grid < 2.1.16 - Reflected Cross-Site Scripting via keyword
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Post Grid WordPress plugin before 2.1.16 does not escape the keyword parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting in pages containing a Post Grid with a search form
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Post Grid | 2.1.16 to before 2.1.16 | 2.1.16 | Patch available | CNA |
- Post Grid VendorUnknown Affected 2.1.16 to before 2.1.16 Fixed in 2.1.16 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:* | before 2.1.16 | Vulnerable | PickPlugins |
- cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:* Versions before 2.1.16 Vulnerable ·PickPlugins
Remediation
- Fix · CNA Post Grid (Unknown) Fixed in 2.1.16
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Post Grid 2.1.16
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-00370 Post Grid < 2.1.16 - Reflected Cross-Site Scripting via post_typesPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24986
- 2026-10-03 Alias added: GHSA-hgmh-vm7j-q2wp
References
More PickPlugins Post Grid vulnerabilities
- TI-2024-08948 Post Grid and Gutenberg Blocks < 2.2.93 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-00811 Combo Blocks < 2.2.76 - Unauthenticated Password Protected Posts Access CVSS 3.1MEDIUM 5.4
- TI-2024-07651 Post Grid and Gutenberg Blocks 2.2.87 - 2.2.90 - Authenticated (Subscriber+) Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2020-18382 PHP Object injection vulnerabilities in the Team Showcase plugin before 1.22.16 for… CVSS 3.1HIGH 8.8
- TI-2020-18381 PHP Object injection vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress… CVSS 3.1HIGH 8.8
- TI-2024-12450 Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor… CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24986 · CVE Program
- CVE-2021-24986 · NVD
- FIRST EPSS
- GHSA-hgmh-vm7j-q2wp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences