Read the docs
TI-2022-00370 Aliases CVE-2022-0447GHSA-rgf7-3xqq-822p

Post Grid < 2.1.16 - Reflected Cross-Site Scripting via post_types

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Post Grid WordPress plugin before 2.1.16 does not sanitise and escape the post_types parameter before outputting it back in the response of the post_grid_update_taxonomies_terms_by_posttypes AJAX action, available to any authenticated users, leading to a Reflected Cross-Site Scripting

Why it matters now

EPSS 0.00641 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Post Grid (Unknown): 2.1.16

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPost Grid2.1.16 to before 2.1.162.1.16Patch availableCNA
  • Post Grid VendorUnknown Affected 2.1.16 to before 2.1.16 Fixed in 2.1.16 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:*before 2.1.16VulnerablePickPlugins
  • cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:* Versions before 2.1.16 Vulnerable ·PickPlugins

Remediation

  • Fix · CNA Post Grid (Unknown) Fixed in 2.1.16

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Post Grid 2.1.16

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2021-07265 Post Grid < 2.1.16 - Reflected Cross-Site Scripting via keywordPriority LOW 29

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0447
  2. 2026-10-03 Alias added: GHSA-rgf7-3xqq-822p
  3. 2026-10-21 EPSS moved to the 50th–90th percentile

References

  • TI-2024-08948 Post Grid and Gutenberg Blocks < 2.2.93 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-00811 Combo Blocks < 2.2.76 - Unauthenticated Password Protected Posts Access CVSS 3.1MEDIUM 5.4
  • TI-2024-07651 Post Grid and Gutenberg Blocks 2.2.87 - 2.2.90 - Authenticated (Subscriber+) Privilege Escalation CVSS 3.1HIGH 8.8
  • TI-2020-18382 PHP Object injection vulnerabilities in the Team Showcase plugin before 1.22.16 for… CVSS 3.1HIGH 8.8
  • TI-2020-18381 PHP Object injection vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress… CVSS 3.1HIGH 8.8
  • TI-2024-12450 Post Grid, Slider & Carousel Ultimate – with Shortcode, Gutenberg Block & Elementor… CVSS 3.1HIGH 8.8
See all 13 →

Sources