Read the docs
TI-2022-00164 Aliases CVE-2022-0228GHSA-w3jc-m34v-m835

Popup Builder < 4.0.7 - Admin+ SQL Injection

Priority MEDIUM 40CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The Popup Builder WordPress plugin before 4.0.7 does not validate and properly escape the orderby and order parameters before using them in a SQL statement in the admin dashboard, which could allow high privilege users to perform SQL injection

Why it matters now

EPSS 0.05263 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Popup Builder – Create highly converting, mobile friendly marketing popups. (Unknown): 4.0.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPopup Builder – Create highly converting, mobile friendly marketing popups.4.0.7 to before 4.0.74.0.7Patch availableCNA
  • Popup Builder – Create highly converting, mobile friendly marketing popups. VendorUnknown Affected 4.0.7 to before 4.0.7 Fixed in 4.0.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:*before 4.0.7Vulnerablepopupbuilder
  • cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:* Versions before 4.0.7 Vulnerable ·popupbuilder

Remediation

  • Fix · CNA Popup Builder – Create highly converting, mobile friendly marketing popups. (Unknown) Fixed in 4.0.7

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Popup Builder – Create highly converting, mobile friendly marketing popups. 4.0.7

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2021-07360 Popup Builder < 4.0.7 - LFI to RCEPriority MEDIUM 46

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0228
  2. 2026-10-03 Alias added: GHSA-w3jc-m34v-m835

References

  • TI-2022-00402 Popup Builder < 4.1.1 - SQL Injection to Reflected Cross-Site Scripting CVSS 3.1CRITICAL 9.8
  • TI-2023-05777 popup-builder < 4.2.6 - Admin+ SSRF & File Read CVSS 3.1HIGH 7.5
  • TI-2024-08748 Popup Builder < 4.3.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2020-07226 The Popup Builder plugin 2.2.8 through 2.6.7.6 for WordPress is vulnerable to SQL… CVSS 3.1CRITICAL 9.8
  • TI-2019-10917 A SQL injection vulnerability exists in the Sygnoos Popup Builder plugin before 3.45 for… CVSS 3.1CRITICAL 9.8
  • TI-2021-07360 Popup Builder < 4.0.7 - LFI to RCE CVSS 3.1HIGH 8.8
See all 17 →

Sources