Read the docs
TI-2021-07369 Aliases CVE-2021-25091GHSA-76j9-mfwr-cgfp

Link Library < 7.2.9 - Reflected Cross-Site Scripting

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Link Library WordPress plugin before 7.2.9 does not sanitise and escape the settingscopy parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting

Why it matters now

EPSS 0.008 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Link Library (Unknown): 7.2.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownLink Library7.2.9 to before 7.2.97.2.9Patch availableCNA
  • Link Library VendorUnknown Affected 7.2.9 to before 7.2.9 Fixed in 7.2.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ylefebvre:link_library:*:*:*:*:*:wordpress:*:*before 7.2.9Vulnerablejackdewey
  • cpe:2.3:a:ylefebvre:link_library:*:*:*:*:*:wordpress:*:* Versions before 7.2.9 Vulnerable ·jackdewey

Remediation

  • Fix · CNA Link Library (Unknown) Fixed in 7.2.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25091
  2. 2026-10-03 Alias added: GHSA-76j9-mfwr-cgfp

References

  • TI-2022-03844 Link Library < 7.4.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-16389 WordPress Link Library Plugin <= 7.5.13 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-01455 Link Library <= 7.6 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.5
  • TI-2021-07371 Link Library < 7.2.8 - Unauthenticated Arbitrary Links Deletion CVSS 3.1HIGH 7.5
  • TI-2024-19297 WordPress Link Library plugin <= 7.6 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-25945 WordPress Link Library plugin <= 7.7.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
See all 14 →

Sources