Affected versions of Atlassian Confluence Server allow remote attackers to view…
Priority HIGH 81Exploited in the wildCWE-425Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-425.
Summary
Affected versions of Atlassian Confluence Server allow remote attackers to view restricted resources via a Pre-Authorization Arbitrary File Read vulnerability in the /s/ endpoint. The affected versions are before version 7.4.10, and from version 7.5.0 before 7.12.3.
Why it matters now
Exploitation Active In CISA KEV since 2022-03-28CISA due date 2022-04-18Known ransomware use
EPSS 0.99937 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Confluence Server (Atlassian): 7.4.10, 7.12.3Confluence Data Center (Atlassian): 7.4.10, 7.12.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Server | before 7.4.10; 7.5.0 and later; before 7.12.3 | 7.4.10, 7.12.3 | Patch available | CNA |
| Atlassian | Confluence Data Center | before 7.4.10; 7.5.0 and later; before 7.12.3 | 7.4.10, 7.12.3 | Patch available | CNA |
Remediation
- Fix · CNA Confluence Server (Atlassian) Fixed in 7.4.10, 7.12.3
- Fix · CNA Confluence Data Center (Atlassian) Fixed in 7.4.10, 7.12.3
Timeline
- 2022-03-28 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2021-26085
- 2026-10-03 Alias added: GHSA-8mjc-qhq2-3xm8
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-26085 · CVE Program
- CVE-2021-26085 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-8mjc-qhq2-3xm8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences