Read the docs
TI-2021-15501 Aliases CVE-2021-37626GHSA-r6mv-ppjc-4hgr

PHP file inclusion via insert tags

Priority LOW 34CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Contao is an open source CMS that allows you to create websites and scalable web applications. In affected versions it is possible to load PHP files by entering insert tags in the Contao back end. Installations are only affected if they have untrusted back end users who have the rights to modify fields that are shown in the front end. Update to Contao 4.4.56, 4.9.18 or 4.11.7 to resolve. If you cannot update then disable the login for untrusted back end users.

Why it matters now

EPSS 0.01254 69th percentileScored 2026-11-07
Fix Fixed contao (contao): 4.4.56, 4.9.18, 4.11.7contao/core-bundle (Packagist): 4.4.56, 4.9.18, 4.11.7+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
contaocontao4.0.0 to before 4.4.56; 4.5.0 to before 4.9.18; 4.10.0 to before 4.11.74.4.56, 4.9.18, 4.11.7Patch availableCNA
—contao/core-bundle (Packagist)4.0.0 to before 4.4.564.4.56Patch availableGHSA-r6mv-ppjc-4hgr
—contao/core-bundle (Packagist)4.5.0 to before 4.9.184.9.18Patch availableGHSA-r6mv-ppjc-4hgr
—contao/core-bundle (Packagist)4.10.0 to before 4.11.74.11.7Patch availableGHSA-r6mv-ppjc-4hgr
—contao/contao (Packagist)4.0.0 to before 4.4.564.4.56Patch availableGHSA-r6mv-ppjc-4hgr
—contao/contao (Packagist)4.5.0 to before 4.9.184.9.18Patch availableGHSA-r6mv-ppjc-4hgr
—contao/contao (Packagist)4.10.0 to before 4.11.74.11.7Patch availableGHSA-r6mv-ppjc-4hgr
  • contao Vendorcontao Affected 4.0.0 to before 4.4.56; 4.5.0 to before 4.9.18; 4.10.0 to before 4.11.7 Fixed in 4.4.56, 4.9.18, 4.11.7 Patch available CNA
  • contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.4.56 Fixed in 4.4.56 Patch available GHSA-r6mv-ppjc-4hgr
  • contao/core-bundle (Packagist) Vendor— Affected 4.5.0 to before 4.9.18 Fixed in 4.9.18 Patch available GHSA-r6mv-ppjc-4hgr
  • contao/core-bundle (Packagist) Vendor— Affected 4.10.0 to before 4.11.7 Fixed in 4.11.7 Patch available GHSA-r6mv-ppjc-4hgr
  • contao/contao (Packagist) Vendor— Affected 4.0.0 to before 4.4.56 Fixed in 4.4.56 Patch available GHSA-r6mv-ppjc-4hgr
  • contao/contao (Packagist) Vendor— Affected 4.5.0 to before 4.9.18 Fixed in 4.9.18 Patch available GHSA-r6mv-ppjc-4hgr
  • contao/contao (Packagist) Vendor— Affected 4.10.0 to before 4.11.7 Fixed in 4.11.7 Patch available GHSA-r6mv-ppjc-4hgr

CPE configurations NVD · 10

CPEVersionsRoleVendor
cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:*4.4.0 to before 4.4.56; 4.9.0 to before 4.9.18; 4.11.0 to before 4.11.7Vulnerablecontao
cpe:2.3:a:contao:contao:4.0.0:*:*:*:*:*:*:*4.0.0Vulnerablecontao
cpe:2.3:a:contao:contao:4.1.0:*:*:*:*:*:*:*4.1.0Vulnerablecontao
cpe:2.3:a:contao:contao:4.2.0:*:*:*:*:*:*:*4.2.0Vulnerablecontao
cpe:2.3:a:contao:contao:4.3.0:*:*:*:*:*:*:*4.3.0Vulnerablecontao
cpe:2.3:a:contao:contao:4.5.0:*:*:*:*:*:*:*4.5.0Vulnerablecontao
cpe:2.3:a:contao:contao:4.6.0:*:*:*:*:*:*:*4.6.0Vulnerablecontao
cpe:2.3:a:contao:contao:4.7.0:*:*:*:*:*:*:*4.7.0Vulnerablecontao
cpe:2.3:a:contao:contao:4.8.0:*:*:*:*:*:*:*4.8.0Vulnerablecontao
cpe:2.3:a:contao:contao:4.10.0:*:*:*:*:*:*:*4.10.0Vulnerablecontao
  • cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 4.4.0 to before 4.4.56; 4.9.0 to before 4.9.18; 4.11.0 to before 4.11.7 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.3.0:*:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.5.0:*:*:*:*:*:*:* Versions 4.5.0 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.6.0:*:*:*:*:*:*:* Versions 4.6.0 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.7.0:*:*:*:*:*:*:* Versions 4.7.0 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.8.0:*:*:*:*:*:*:* Versions 4.8.0 Vulnerable ·contao
  • cpe:2.3:a:contao:contao:4.10.0:*:*:*:*:*:*:* Versions 4.10.0 Vulnerable ·contao

Remediation

  • Fix · CNA contao (contao) Fixed in 4.4.56, 4.9.18, 4.11.7
  • Fix · GHSA-r6mv-ppjc-4hgr contao/core-bundle (Packagist) Fixed in 4.4.56 Advisory →
  • Fix · GHSA-r6mv-ppjc-4hgr contao/core-bundle (Packagist) Fixed in 4.9.18 Advisory →
  • Fix · GHSA-r6mv-ppjc-4hgr contao/core-bundle (Packagist) Fixed in 4.11.7 Advisory →
  • Fix · GHSA-r6mv-ppjc-4hgr contao/contao (Packagist) Fixed in 4.4.56 Advisory →
  • Fix · GHSA-r6mv-ppjc-4hgr contao/contao (Packagist) Fixed in 4.9.18 Advisory →
  • Fix · GHSA-r6mv-ppjc-4hgr contao/contao (Packagist) Fixed in 4.11.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-37626
  2. 2026-10-03 Alias added: GHSA-r6mv-ppjc-4hgr

References

  • TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
  • TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
  • TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
  • TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
  • TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
  • TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
See all 31 →

Sources