Business Logic Errors in publify/publify
Priority LOW 36CWE-840Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Business Logic Errors in GitHub repository publify/publify prior to 9.2.7.
Why it matters now
EPSS 0.01567 75th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed publify/publify (publify): 9.2.7publify_core (RubyGems): 9.2.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| publify | publify/publify | before 9.2.7 | 9.2.7 | Patch available | CNA |
| — | publify_core (RubyGems) | before 9.2.7 | 9.2.7 | Patch available | GHSA-x3rq-r3cm-5vc4 |
- publify/publify Vendorpublify Affected before 9.2.7 Fixed in 9.2.7 Patch available CNA
- publify_core (RubyGems) Vendor— Affected before 9.2.7 Fixed in 9.2.7 Patch available GHSA-x3rq-r3cm-5vc4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* | before 9.2.7 | Vulnerable | publify_core |
- cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* Versions before 9.2.7 Vulnerable ·publify_core
Remediation
- Fix · CNA publify/publify (publify) Fixed in 9.2.7
- Fix · GHSA-x3rq-r3cm-5vc4 publify_core (RubyGems) Fixed in 9.2.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0524
- 2026-10-03 Alias added: GHSA-x3rq-r3cm-5vc4
References
More publify vulnerabilities
- TI-2023-00284 Improper Input Validation in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2022-01678 Integer Overflow or Wraparound in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2023-00540 Weak Password Requirements in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2022-02609 Insecure Storage of Sensitive Information in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2024-26267 Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction CVSS 4.0LOW 1.8
- TI-2014-02574 Publify before 8.0.1 is vulnerable to a Denial of Service attack CVSS 3.1HIGH 7.5
Sources
- CVE-2022-0524 · CVE Program
- CVE-2022-0524 · NVD
- FIRST EPSS
- GHSA-x3rq-r3cm-5vc4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences