Improper Access Control in publify/publify
Priority LOW 30CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Improper Access Control in GitHub repository publify/publify prior to 9.2.8.
Why it matters now
EPSS 0.00841 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed publify/publify (publify): 9.2.8publify_core (RubyGems): 9.2.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| publify | publify/publify | before 9.2.8 | 9.2.8 | Patch available | CNA |
| — | publify_core (RubyGems) | before 9.2.8 | 9.2.8 | Patch available | GHSA-79m3-q3wh-c3qm |
- publify/publify Vendorpublify Affected before 9.2.8 Fixed in 9.2.8 Patch available CNA
- publify_core (RubyGems) Vendor— Affected before 9.2.8 Fixed in 9.2.8 Patch available GHSA-79m3-q3wh-c3qm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* | before 9.2.8 | Vulnerable | publify_core |
- cpe:2.3:a:publify_project:publify:*:*:*:*:*:*:*:* Versions before 9.2.8 Vulnerable ·publify_core
Remediation
- Fix · CNA publify/publify (publify) Fixed in 9.2.8
- Fix · GHSA-79m3-q3wh-c3qm publify_core (RubyGems) Fixed in 9.2.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
publify/publify 9.2.8
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-00496 Code Injection in publify/publifyPriority LOW 31
- TI-2022-01424 Leaking password protected articles content due to improper access control in publify/publifyPriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0574
- 2026-10-03 Alias added: GHSA-79m3-q3wh-c3qm
References
More publify vulnerabilities
- TI-2023-00284 Improper Input Validation in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2022-01678 Integer Overflow or Wraparound in publify/publify CVSS 3.1CRITICAL 9.8
- TI-2023-00540 Weak Password Requirements in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2022-02609 Insecure Storage of Sensitive Information in publify/publify CVSS 3.1MEDIUM 6.5
- TI-2024-26267 Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction CVSS 4.0LOW 1.8
- TI-2022-00444 Business Logic Errors in publify/publify CVSS 3.1HIGH 7.5
Sources
- CVE-2022-0574 · CVE Program
- CVE-2022-0574 · NVD
- FIRST EPSS
- GHSA-79m3-q3wh-c3qm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences