Cross-site Scripting (XSS) - Stored in librenms/librenms
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) - Stored in Packagist librenms/librenms prior to 22.2.0.
Why it matters now
EPSS 0.00847 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms/librenms (librenms): 22.2.0librenms/librenms (Packagist): 22.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms/librenms | before 22.2.0 | 22.2.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 22.2.0 | 22.2.0 | Patch available | GHSA-hxmr-5gv9-6p8v |
- librenms/librenms Vendorlibrenms Affected before 22.2.0 Fixed in 22.2.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 22.2.0 Fixed in 22.2.0 Patch available GHSA-hxmr-5gv9-6p8v
Remediation
- Fix · CNA librenms/librenms (librenms) Fixed in 22.2.0
- Fix · GHSA-hxmr-5gv9-6p8v librenms/librenms (Packagist) Fixed in 22.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0575
- 2026-10-03 Alias added: GHSA-hxmr-5gv9-6p8v
References
Advisory 2
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-0575 · CVE Program
- CVE-2022-0575 · NVD
- FIRST EPSS
- GHSA-hxmr-5gv9-6p8v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences