Read the docs
TI-2022-00494 Aliases CVE-2022-0576GHSA-rp34-85x3-3764

Cross-site Scripting (XSS) - Generic in librenms/librenms

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Cross-site Scripting (XSS) - Generic in Packagist librenms/librenms prior to 22.1.0.

Why it matters now

EPSS 0.00998 62nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms/librenms (librenms): 22.1.0librenms/librenms (Packagist): 22.1.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
librenmslibrenms/librenmsbefore 22.1.022.1.0Patch availableCNA
—librenms/librenms (Packagist)before 22.1.022.1.0Patch availableGHSA-rp34-85x3-3764
  • librenms/librenms Vendorlibrenms Affected before 22.1.0 Fixed in 22.1.0 Patch available CNA
  • librenms/librenms (Packagist) Vendor— Affected before 22.1.0 Fixed in 22.1.0 Patch available GHSA-rp34-85x3-3764

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*before 22.2.0Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* Versions before 22.2.0 Vulnerable ·librenms

Remediation

  • Fix · CNA librenms/librenms (librenms) Fixed in 22.1.0
  • Fix · GHSA-rp34-85x3-3764 librenms/librenms (Packagist) Fixed in 22.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0576
  2. 2026-10-03 Alias added: GHSA-rp34-85x3-3764

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources