Improper Authorization in librenms/librenms
Priority LOW 31CWE-285Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
Improper Authorization in Packagist librenms/librenms prior to 22.2.0.
Why it matters now
EPSS 0.0102 63rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms/librenms (librenms): 22.2.0librenms/librenms (Packagist): 22.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms/librenms | before 22.2.0 | 22.2.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 22.2.0 | 22.2.0 | Patch available | GHSA-ppfm-rj6p-38q6 |
- librenms/librenms Vendorlibrenms Affected before 22.2.0 Fixed in 22.2.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 22.2.0 Fixed in 22.2.0 Patch available GHSA-ppfm-rj6p-38q6
Remediation
- Fix · CNA librenms/librenms (librenms) Fixed in 22.2.0
- Fix · GHSA-ppfm-rj6p-38q6 librenms/librenms (Packagist) Fixed in 22.2.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
librenms/librenms 22.2.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-00505 Missing Authorization in librenms/librenmsPriority LOW 33
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0587
- 2026-10-03 Alias added: GHSA-ppfm-rj6p-38q6
References
Advisory 2
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-0587 · CVE Program
- CVE-2022-0587 · NVD
- FIRST EPSS
- GHSA-ppfm-rj6p-38q6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences