Read the docs
TI-2022-01754 Aliases CVE-2022-1894GHSA-f7v6-8cx8-mqp8

Popup Builder < 4.1.11 - Admin+ Stored Cross-Site Scripting

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Popup Builder WordPress plugin before 4.1.11 does not escape and sanitize some settings, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when the unfiltred_html is disallowed

Why it matters now

EPSS 0.00588 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Popup Builder – Create highly converting, mobile friendly marketing popups. (Unknown): 4.1.11

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPopup Builder – Create highly converting, mobile friendly marketing popups.4.1.11 to before 4.1.114.1.11Patch availableCNA
  • Popup Builder – Create highly converting, mobile friendly marketing popups. VendorUnknown Affected 4.1.11 to before 4.1.11 Fixed in 4.1.11 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:*before 4.1.11Vulnerablepopupbuilder
  • cpe:2.3:a:sygnoos:popup_builder:*:*:*:*:*:wordpress:*:* Versions before 4.1.11 Vulnerable ·popupbuilder

Remediation

  • Fix · CNA Popup Builder – Create highly converting, mobile friendly marketing popups. (Unknown) Fixed in 4.1.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1894
  2. 2026-10-03 Alias added: GHSA-f7v6-8cx8-mqp8

References

  • TI-2022-00402 Popup Builder < 4.1.1 - SQL Injection to Reflected Cross-Site Scripting CVSS 3.1CRITICAL 9.8
  • TI-2023-05777 popup-builder < 4.2.6 - Admin+ SSRF & File Read CVSS 3.1HIGH 7.5
  • TI-2024-08748 Popup Builder < 4.3.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2020-07226 The Popup Builder plugin 2.2.8 through 2.6.7.6 for WordPress is vulnerable to SQL… CVSS 3.1CRITICAL 9.8
  • TI-2019-10917 A SQL injection vulnerability exists in the Sygnoos Popup Builder plugin before 3.45 for… CVSS 3.1CRITICAL 9.8
  • TI-2021-07360 Popup Builder < 4.0.7 - LFI to RCE CVSS 3.1HIGH 8.8
See all 17 →

Sources