WooCommerce < 6.6.0 - Admin+ Stored HTML Injection
Priority LOW 23CWE-116Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The WooCommerce WordPress plugin before 6.6.0 is vulnerable to stored HTML injection due to lack of escaping and sanitizing in the payment gateway titles
Why it matters now
EPSS 0.00667 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WooCommerce (Unknown): 6.6.0woocommerce/woocommerce (Packagist): 6.6.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WooCommerce | before 6.6.0 | 6.6.0 | Patch available | CNA |
| — | woocommerce/woocommerce (Packagist) | before 6.6.0 | 6.6.0 | Patch available | GHSA-jwvf-28fg-g4xg |
- WooCommerce VendorUnknown Affected before 6.6.0 Fixed in 6.6.0 Patch available CNA
- woocommerce/woocommerce (Packagist) Vendor— Affected before 6.6.0 Fixed in 6.6.0 Patch available GHSA-jwvf-28fg-g4xg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* | before 6.6.0 | Vulnerable | WooCommerce |
- cpe:2.3:a:woocommerce:woocommerce:*:*:*:*:*:wordpress:*:* Versions before 6.6.0 Vulnerable ·WooCommerce
Remediation
- Fix · CNA WooCommerce (Unknown) Fixed in 6.6.0
- Fix · GHSA-jwvf-28fg-g4xg woocommerce/woocommerce (Packagist) Fixed in 6.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2099
- 2026-10-03 Alias added: GHSA-jwvf-28fg-g4xg
- 2026-10-04 EPSS moved to the 50th–90th percentile
References
More Woocommerce vulnerabilities
- TI-2022-00684 WooCommerce < 6.2.1 - Subscriber+ Arbitrary Comment Deletion CVSS 3.1MEDIUM 4.3
- TI-2017-13530 In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible… CVSS 3.0HIGH 8.8
- TI-2019-15109 WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site… CVSS 3.1HIGH 8.8
- TI-2018-14697 The logging system of the Automattic WooCommerce plugin before 3.4.6 for WordPress is… CVSS 3.0HIGH 8.1
- TI-2023-28650 WordPress WooCommerce Plugin <= 8.2.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-09228 WooCommerce <= 9.0.2 - Unauthenticated HTML Injection CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-2099 · CVE Program
- CVE-2022-2099 · NVD
- FIRST EPSS
- GHSA-jwvf-28fg-g4xg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences