NEX-Forms < 7.9.7 - Authenticated SQLi
Priority MEDIUM 54CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The NEX-Forms WordPress plugin before 7.9.7 does not properly sanitise and escape user input before using it in SQL statements, leading to SQL injections. The attack can be executed by anyone who is permitted to view the forms statistics chart, by default administrators, however can be configured otherwise via the plugin settings.
Why it matters now
EPSS 0.1465 96th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed NEX-Forms – Ultimate Form Builder – Contact forms and much more (Unknown): 7.9.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | NEX-Forms – Ultimate Form Builder – Contact forms and much more | 7.9.7 to before 7.9.7 | 7.9.7 | Patch available | CNA |
- NEX-Forms – Ultimate Form Builder – Contact forms and much more VendorUnknown Affected 7.9.7 to before 7.9.7 Fixed in 7.9.7 Patch available CNA
Remediation
- Fix · CNA NEX-Forms – Ultimate Form Builder – Contact forms and much more (Unknown) Fixed in 7.9.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3142
- 2026-10-03 Alias added: GHSA-5www-q64q-vx68
References
More webaways Nex-forms vulnerabilities
- TI-2023-01989 NEX-Forms < 8.4 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2023-00416 NEX-Forms < 8.4.4 - Authenticated Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-00257 NEX-Forms < 8.3.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2015-07829 The nex-forms-express-wp-form-builder plugin before 4.6.1 for WordPress has SQL injection… CVSS 3.1CRITICAL 9.8
- TI-2023-28559 WordPress NEX-Forms – Ultimate Form Builder Plugin <= 8.5.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-36006 WordPress NEX-Forms plugin <= 8.7.8 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
Sources
- CVE-2022-3142 · CVE Program
- CVE-2022-3142 · NVD
- FIRST EPSS
- GHSA-5www-q64q-vx68 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences