Read the docs
TI-2023-00416 Aliases CVE-2023-0439GHSA-42c6-gcr4-xh6h

NEX-Forms < 8.4.4 - Authenticated Stored XSS

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

The NEX-Forms WordPress plugin before 8.4.4 does not escape its form name, which could lead to Stored Cross-Site Scripting issues. By default only SuperAdmins (in multisite) / admins (in single site) can create forms, however there is a settings allowing them to give lower roles access to such feature.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0037 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed NEX-Forms (Unknown): 8.4.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownNEX-Formsbefore 8.4.48.4.4Patch availableCNA
  • NEX-Forms VendorUnknown Affected before 8.4.4 Fixed in 8.4.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:basixonline:nex-forms:*:*:*:*:*:wordpress:*:*before 8.4.4Vulnerablewebaways
  • cpe:2.3:a:basixonline:nex-forms:*:*:*:*:*:wordpress:*:* Versions before 8.4.4 Vulnerable ·webaways

Remediation

  • Fix · CNA NEX-Forms (Unknown) Fixed in 8.4.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0439
  2. 2026-10-03 Alias added: GHSA-42c6-gcr4-xh6h

References

  • TI-2023-01989 NEX-Forms < 8.4 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
  • TI-2023-00257 NEX-Forms < 8.3.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2022-02901 NEX-Forms < 7.9.7 - Authenticated SQLi CVSS 3.1HIGH 8.8
  • TI-2015-07829 The nex-forms-express-wp-form-builder plugin before 4.6.1 for WordPress has SQL injection… CVSS 3.1CRITICAL 9.8
  • TI-2023-28559 WordPress NEX-Forms – Ultimate Form Builder Plugin <= 8.5.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-36006 WordPress NEX-Forms plugin <= 8.7.8 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
See all 20 →

Sources