NEX-Forms < 8.3.3 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The NEX-Forms WordPress plugin before 8.3.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00503 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed NEX-Forms (Unknown): 8.3.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | NEX-Forms | before 8.3.3 | 8.3.3 | Patch available | CNA |
- NEX-Forms VendorUnknown Affected before 8.3.3 Fixed in 8.3.3 Patch available CNA
Remediation
- Fix · CNA NEX-Forms (Unknown) Fixed in 8.3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0272
- 2026-10-03 Alias added: GHSA-j9w6-ph9x-3m55
References
More webaways Nex-forms vulnerabilities
- TI-2023-01989 NEX-Forms < 8.4 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2023-00416 NEX-Forms < 8.4.4 - Authenticated Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2022-02901 NEX-Forms < 7.9.7 - Authenticated SQLi CVSS 3.1HIGH 8.8
- TI-2015-07829 The nex-forms-express-wp-form-builder plugin before 4.6.1 for WordPress has SQL injection… CVSS 3.1CRITICAL 9.8
- TI-2023-28559 WordPress NEX-Forms – Ultimate Form Builder Plugin <= 8.5.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-36006 WordPress NEX-Forms plugin <= 8.7.8 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
Sources
- CVE-2023-0272 · CVE Program
- CVE-2023-0272 · NVD
- FIRST EPSS
- GHSA-j9w6-ph9x-3m55 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences