Read the docs
TI-2023-01989 Aliases CVE-2023-2114GHSA-8grp-3h33-9g72

NEX-Forms < 8.4 - Admin+ SQL Injection

Priority HIGH 67CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.

Summary

The NEX-Forms WordPress plugin before 8.4 does not properly escape the `table` parameter, which is populated with user input, before concatenating it to an SQL query.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.44904 98th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed NEX-Forms (Unknown): 8.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownNEX-Formsbefore 8.48.4Patch availableCNA
  • NEX-Forms VendorUnknown Affected before 8.4 Fixed in 8.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:basixonline:nex-forms:*:*:*:*:*:wordpress:*:*before 8.4Vulnerablewebaways
  • cpe:2.3:a:basixonline:nex-forms:*:*:*:*:*:wordpress:*:* Versions before 8.4 Vulnerable ·webaways

Remediation

  • Fix · CNA NEX-Forms (Unknown) Fixed in 8.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-2114
  2. 2026-10-03 Alias added: GHSA-8grp-3h33-9g72

References

  • TI-2023-00416 NEX-Forms < 8.4.4 - Authenticated Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2023-00257 NEX-Forms < 8.3.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2022-02901 NEX-Forms < 7.9.7 - Authenticated SQLi CVSS 3.1HIGH 8.8
  • TI-2015-07829 The nex-forms-express-wp-form-builder plugin before 4.6.1 for WordPress has SQL injection… CVSS 3.1CRITICAL 9.8
  • TI-2023-28559 WordPress NEX-Forms – Ultimate Form Builder Plugin <= 8.5.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-36006 WordPress NEX-Forms plugin <= 8.7.8 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
See all 20 →

Sources