Rate limiting Bypass on login page in libreNMS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Denial of service
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-307 and CWE-770.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring which includes support for a wide range of network hardware and operating systems. In affected versions the login method has no rate limit. An attacker may be able to leverage this vulnerability to gain access to user accounts. This issue has been addressed in version 23.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 23.11.0 | 23.11.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 23.11.0 | 23.11.0 | Patch available | GHSA-rq42-58qf-v3qx |
- librenms Vendorlibrenms Affected before 23.11.0 Fixed in 23.11.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 23.11.0 Fixed in 23.11.0 Patch available GHSA-rq42-58qf-v3qx
Remediation
- Fix · CNA librenms (librenms) Fixed in 23.11.0
- Fix · GHSA-rq42-58qf-v3qx librenms/librenms (Packagist) Fixed in 23.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46745
- 2026-10-03 Alias added: GHSA-rq42-58qf-v3qx
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-46745 · CVE Program
- CVE-2023-46745 · NVD
- FIRST EPSS
- GHSA-rq42-58qf-v3qx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences